Bug 456518 - multicall fails with getbugssimple
multicall fails with getbugssimple
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 07:29 EDT by Jan Hutař
Modified: 2009-06-10 03:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 03:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-07-24 07:29:19 EDT
Description of problem:
Maybe I'm doing something wrong, but I have tried to get info about more bugs 
similar as in /usr/bin/bugzilla code. I have this peace of code:


import bugzilla
bz = bugzilla.Bugzilla(url='https://bugzilla.redhat.com/xmlrpc.cgi')
bz.login('jhutar@redhat.com', 'xyz')
bug_ids = (123456, 789123, 456789)
bug_list = bz.getbugssimple(bug_ids)
for id, bug in zip(bug_ids, bug_list):
  print id
  print bug


I'm getting only first bug, others are translated by 
replace_getbug_errors_with_None to None.


Version-Release number of selected component (if applicable):
python-bugzilla-0.3-1.fc9.noarch


How reproducible:
always


Steps to Reproduce:
1. run the script above


Actual results:
123456
#123456 blablabla
789123
None
456789
None


Expected results:
123456
#123456 blablabla
789123
#789123 blablabla
456789
#456789 blablabla


Additional info:
Filtered "None" messages are filtered because raw results contails this error 
message:

Error: DBD::mysql::db do failed: The MySQL server is running with the --read-
only option so it cannot execute this statement at Bugzilla/Auth/Cookie.pm line 
318
	Bugzilla::Auth::Cookie::_insert_new_session(203706) called at Bugzilla/
Auth/Cookie.pm line 202
	Bugzilla::Auth::Cookie::set_cookie_login_info('Bugzilla::Auth::Cookie', 
203706, 'undef', 'undef') called at Bugzilla/Auth/RPC.pm line 63
	Bugzilla::Auth::RPC::login('Bugzilla::Auth::RPC', 0, 
'jhutar@redhat.com', 'xyz') called at Bugzilla.pm line 99
	Bugzilla::login('undef', 'undef', 'jhutar@redhat.com', 'xyz') called at 
Bugzilla/RPC/Bug.pm line 127
	Bugzilla::RPC::Bug::getBugSimple(430155, 'jhutar@redhat.com', 'xyz') 
called at /var/www/html/bugzilla/xmlrpc.cgi line 104
	eval {...} called at /var/www/html/bugzilla/xmlrpc.cgi line 102
	system::multicall('system', 'ARRAY(0x1d38ab0)') called at /usr/lib/
perl5/vendor_perl/5.8.5/SOAP/Lite.pm line 2474
	eval {...} called at /usr/lib/perl5/vendor_perl/5.8.5/SOAP/Lite.pm line 
2462
	eval {...} called at /usr/lib/perl5/vendor_perl/5.8.5/SOAP/Lite.pm line 
2433
	SOAP::Server::handle('Bugzilla::RPC=HASH(0x1b5cb60)', '<?xml version=
\'1.0\'?>\x{a}<methodCall>\x{a}<methodName>system.multi...') called at /usr/lib/
perl5/vendor_perl/5.8.5/SOAP/Transport/HTTP.pm line 317
	SOAP::Transport::HTTP::Server::handle('Bugzilla::RPC=HASH(0x1b5cb60)') 
called at /usr/lib/perl5/vendor_perl/5.8.5/SOAP/Transport/HTTP.pm line 408
	SOAP::Transport::HTTP::CGI::handle('Bugzilla::RPC=HASH(0x1b5cb60)') 
called at /var/www/html/bugzilla/xmlrpc.cgi line 45

package => bugzilla, method => getBugSimple, full_method => 
bugzilla::getBugSimple,  params => [430155,jhutar@redhat.com,xyz]


Thank you in advance for any help.
Comment 1 Will Woods 2008-09-29 13:35:55 EDT
I'm pretty sure this was a transient bug in the server xmlrpc code - have you tried this code snippet again recently?

You could also try using python-bugzilla 0.4rc2 (available in rawhide, but works in F9/F8/etc.).

If that's not possible, could you give me the exact bug IDs you're trying to fetch? bug #789123 obviously doesn't exist, so returning None there is sensible.
Comment 2 Bug Zapper 2009-06-09 22:13:22 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jan Hutař 2009-06-10 03:46:51 EDT
Yes, you are right. Sorry for not responding. It works now.

Note You need to log in before you can comment on or make changes to this bug.