Bug 456528 - real-time/high-priority scheduling requested, denied
real-time/high-priority scheduling requested, denied
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 09:17 EDT by Stephen
Modified: 2008-07-28 07:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 07:37:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen 2008-07-24 09:17:01 EDT
Description of problem:

The following messages appear in /var/log/messages after boot:

pulseaudio[2562]: main.c: Called SUID root and real-time/high-priority
scheduling was requested in the configuration. However, we lack the necessary
priviliges:
pulseaudio[2562]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to
grant us priviliges. Dropping SUID again.
pulseaudio[2562]: main.c: For enabling real-time scheduling please acquire the
appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase
the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
pulseaudio[2562]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not
permitted
pulseaudio[2562]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not
permitted
pulseaudio[2562]: module-x11-xsmp.c: X11 session manager not running.
pulseaudio[2562]: module.c: Failed to load  module "module-x11-xsmp" (argument:
""): initialization failed.



Version-Release number of selected component (if applicable):

pulseaudio-0.9.10-1.fc9.i386
PolicyKit-0.8-2.fc9.i386
kernel-2.6.25.10-86.fc9.i686
selinux-policy-3.3.1-78.fc9.noarch



Expected results:

I would expect pulseaudio to be in group pulse-rt by default, or that suitable
policykit policy is installed, or that the default pulseaudio config file does
not request hi-prio scheduling.



Additional Info:

This is a fresh install from an F9 live cd, with all updates applied as of
today. No configuration changes have been made to any audio components (as far
as I know).
Comment 1 Lennart Poettering 2008-07-28 07:37:17 EDT
This is not a problem. Due to sceurity reasons we chose not to disable rt
scheduling by default. In order to make it easy to enable RT scheduling we
however enabled it in the config file, so that all that is necessary to actually
enable it is giving a user the appropriate priviliges either by adding him to
pulse-rt or by setting the policykit rights.

Note You need to log in before you can comment on or make changes to this bug.