Bug 456541 - nokia file browsing fails to show any files, should use PC Suite service
nokia file browsing fails to show any files, should use PC Suite service
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: obex-data-server (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 10:33 EDT by Stephen
Modified: 2008-10-15 22:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 22:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sdptool browse 00:18:8D:13:17:B0 > sdptool-browse.out (3.05 KB, text/plain)
2008-07-24 10:33 EDT, Stephen
no flags Details

  None (edit)
Description Stephen 2008-07-24 10:33:55 EDT
Description of problem:

My Nokia 6680 phone appears under 'Computer' as a paired phone. Double clicking
the icon opens a Nautilus window for browsing but there are no files shown. It's
also not possible to drag 'n drop a file onto the window, create a directory,
etc. (permission denied).

I also have a Soney Ericsson 910i and this phone does work -- files show up as
expected.

The problem seems to be that nokia phones (at least this one...) advertise TWO
Obex FTP services: the standard "OBEX File Transfer" service on channel 10, and
a "Nokia OBEX PC Suite Services" on channel 12, which is actually just OBEX FTP
(or at least a workalike).

For example, here's the output of sdptool (full output in attachment):

Service Description: OBEX File Transfer
Service RecHandle: 0x10005
Service Class ID List:
  "OBEX File Transfer" (0x1106)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 10
  "OBEX" (0x0008)
Language Base Attr List:
  code_ISO639: 0x454e
  encoding:    0x6a
  base_offset: 0x100
Profile Descriptor List:
  "OBEX File Transfer" (0x1106)
    Version: 0x0100


and:


Service Name: Nokia OBEX PC Suite Services
Service RecHandle: 0x10007
Service Class ID List:
  UUID 128: 00005005-0000-1000-8000-0002ee000001
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 12
  "OBEX" (0x0008)
Language Base Attr List:
  code_ISO639: 0x454e
  encoding:    0x6a
  base_offset: 0x100
Profile Descriptor List:
  "" (0x00005005-0000-1000-8000-0002ee000001)
    Version: 0x0100


Using the obexftp command line client results in the following. First, try to
list the contents of the standard OBEX FTP service (channel 10):


$ obexftp --bluetooth 00:18:8D:13:17:B0 --channel 10 -l
Connecting...done
Receiving "(null)"...
<?xml version="1.0"?>
<!DOCTYPE folder-listing SYSTEM "obex-folder-listing.dtd">
<folder-listing version="1.0"></folder-listing>
done
Disconnecting...done


And now the Nokia OBEX PC Suite Services, on channel 12:


$ obexftp --bluetooth 00:18:8D:13:17:B0 --channel 12 -l
Connecting...done
Receiving "(null)"...
<?xml version="1.0"?>
<!DOCTYPE folder-listing SYSTEM "obex-folder-listing.dtd"
  [ <!ATTLIST folder mem-type CDATA #IMPLIED>
  <!ATTLIST folder label CDATA #IMPLIED> ]>
<folder-listing version="1.0">
   <folder name="C:" user-perm="RW" mem-type="DEV" label="Phone memory"/>
</folder-listing>done
Disconnecting...done


The second run shows the C: drive. It also works to transfer files.

My guess is that whatever component of bluetooth/nautilus that browses file on a
phone correctly looks for the OBEX FTP service, but this fails with certain/all
nokia phones. It should instead look for both services, and if the Nokia PC
Suite service exists, use it in preference to the standard FTP service. The
protocol itself seems to be the same (at least as far as basic ftp goes).



Version-Release number of selected component (if applicable):

bluez-gnome-0.26-1.fc9.i386

Nokia 6680 phone with S60.2



How reproducible:

All the time.



Steps to Reproduce:
1. connect nokia phone over bluetooth
2. browse phone using nautilus


Actual results:

No files found.



Expected results:

Contents of phone (pictures etc.)



Additional info:

See attachment for output of 'sdptool browse 00:18:8D:13:17:B0 > sdptool-browse.out'
Comment 1 Stephen 2008-07-24 10:33:55 EDT
Created attachment 312565 [details]
sdptool browse 00:18:8D:13:17:B0 > sdptool-browse.out
Comment 2 Fedora Update System 2008-08-22 19:53:18 EDT
obex-data-server-0.3.4-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/obex-data-server-0.3.4-1.fc9
Comment 3 Fedora Update System 2008-09-10 02:55:33 EDT
obex-data-server-0.3.4-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update obex-data-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7442
Comment 4 Stephen 2008-09-10 18:09:57 EDT
I tried obex-data-server-0.3.4-1.fc9 but no joy. Same symptoms. Still seems to be connecting to the same channel with the same results.
Comment 5 Bastien Nocera 2008-09-15 15:46:48 EDT
I think that obex-data-server needs to look for the Nokia PC suite channel as well then. Could you please file another bug about that? Some work is going into obex-data-server's SDP codeaas we speak, and it shouldn't get lost.

The bug the update fixed is for some _other_ Nokia phones that have another service which offers a fully-featured ObexFTP service, whilst the main channel has a crippled down version (ie. same problem as yours, but with a different service name).
Comment 6 Fedora Update System 2008-10-15 22:13:08 EDT
obex-data-server-0.3.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.