Bug 456623 - Use pavucontrol -> pulseaudio uses high cpu usage.
Use pavucontrol -> pulseaudio uses high cpu usage.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-07-24 20:49 EDT by sangu
Modified: 2008-10-24 16:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ls in pacmd (12.31 KB, text/plain)
2008-10-02 11:39 EDT, sangu
no flags Details

  None (edit)
Description sangu 2008-07-24 20:49:38 EDT
Description of problem:
Use pavucontrol ->  pulseaudio uses high cpu usage.

Only after Lanuching pavucontrol, pulseaudio uses cpu usage 40%.

Version-Release number of selected component (if applicable):
0.9.7-0.1.git20080715.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. Launch pavucontrol.
2. See pulseaudio on top.
3.
  
Actual results:


Expected results:


Additional info:
pulseaudio-0.9.11-1.fc10.i386.
Comment 1 Lennart Poettering 2008-08-06 10:10:20 EDT
pavucontrol now shows a volume meter for each device. For that it will configure PA for low-latency mode. Low-latency means high-CPU load. This is hence expected behaviour, somewhat.

OTOH it might be a good idea to not configure it for such a low latency though.
Comment 2 sangu 2008-10-02 11:39:49 EDT
Created attachment 319252 [details]
ls in pacmd

While pavucontrol works, "D: module-alsa-source.c: Wakeup from ALSA! INPUT" prints fast continually.
$ pulseaudio -vvv

[skip]
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
D: module-alsa-source.c: Wakeup from ALSA! INPUT
[skip]
Comment 3 Lennart Poettering 2008-10-24 16:58:28 EDT
I am closing this now since as mentioned this is kind of expected behaviour.

The "wakeup form ALSA" messages might be a sign of bug 462200.

Note You need to log in before you can comment on or make changes to this bug.