Bug 456624 - mplayer uses audio output to alsa, mplayer crashes.
mplayer uses audio output to alsa, mplayer crashes.
Status: CLOSED DUPLICATE of bug 453908
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 21:07 EDT by sangu
Modified: 2008-07-25 06:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 06:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-07-24 21:07:32 EDT
Description of problem:
$ mplayer -ao alsa "a movie file"
[...]
Starting playback...
mplayer: pcm_pulse.c:296: pulse_write: Assertion `pcm->last_size >= (size *
pcm->frame_size)' failed.

mplayer works well with pulse(PulseAudio audio output).

Version-Release number of selected component (if applicable):
0.9.11-1.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. mplayer -ao alsa foobar.avi
2.
3.
  
Actual results:


Expected results:


Additional info:
No problem in pulseaudio-0.9.10-1.fc9.
Installed mplayer is package in livna repository.
<
http://livna-dl.reloumirrors.net/fedora/development/i386/mplayer-1.0-0.94.20080613svn.lvn10.i386.rpm
>
Comment 1 Hans de Goede 2008-07-25 06:29:28 EDT
This is a dup of bug 453908, closing as such.


*** This bug has been marked as a duplicate of 453908 ***

Note You need to log in before you can comment on or make changes to this bug.