Bug 456626 - Redhat enterprise linux 4 update 7 guest suspend hang under xen-3.2.1 and xen unstable
Redhat enterprise linux 4 update 7 guest suspend hang under xen-3.2.1 and xen...
Status: CLOSED DUPLICATE of bug 475849
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-xen (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Don Dutile
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 21:35 EDT by Jonkery Huang
Modified: 2009-06-09 15:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 09:11:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonkery Huang 2008-07-24 21:35:17 EDT
Description of problem:
I have installed a Redhat EL4U7 HVM guest, then issue xm suspend, the command
will hang at xc_save:
1. # ps aux
......
root     16761  0.1  0.9  11264  5984 pts/9    S+   14:17   0:00 python
/usr/sbin/xm suspend 41
root     16763  0.0  0.0   1988   480 ?        S    14:17   0:00
/usr/lib/xen/bin/xc_save 29 41 0 0 4

# strace -p 16763
Process 16763 attached - interrupt to quit
read(0,

seems it is waiting for something.

2. Check with this guest, it has pv dirver installed:
# xm li
Name                                        ID   Mem VCPUs      State   Time(s)
Domain-0                                     0   585     4     r-----   1144.9
OVM_RHEL4U7_X86_HVM_4GB                     40  1024     1     -b----     82.2

# python
Python 2.4.3 (#1, Jun  6 2007, 15:09:38)
[GCC 4.1.1 20070105 (Red Hat 4.1.1-52)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> import xen.lowlevel.xc
>>> from xen.xend.XendConstants import *
>>> xc = xen.lowlevel.xc.xc()
>>> hvm_pvdrv = xc.hvm_get_param(40, HVM_PARAM_CALLBACK_IRQ) >>> if hvm_pvdrv:
...     print "This domain has PV drivers"  ...
This domain has PV drivers

3. Check with RHEL4U7 kernel, HVM_PARAM_CALLBACK_IRQ is set when init
platform-pci which is built in to the kernel.

4. For hvm guest with pv driver, xend will deal with it in a special way, paste
some code from tools/python/xen/xend/XendDomainInfo.py
       # HVM domain shuts itself down only if it has PV drivers
       if self.info.is_hvm():
           hvm_pvdrv = xc.hvm_get_param(self.domid, HVM_PARAM_CALLBACK_IRQ)
           if not hvm_pvdrv:
               code = REVERSE_DOMAIN_SHUTDOWN_REASONS[reason]
               log.info("HVM save:remote shutdown dom %d!", self.domid)
               xc.domain_shutdown(self.domid, code)

In the comment, it says "HVM domain shuts itself down only if it has PV drivers".

5. So this should be a bug of PV driver.
Comment 2 Don Dutile 2008-09-22 16:00:58 EDT
Please provide dom0 & HV details.
Please provide xend log's when error / hang occurs.
Comment 3 Chris Lalancette 2009-02-24 09:11:52 EST
Looking at this again, I'm fairly confident this is a dup of BZ 475849.  We now have a patch pending for that.  I'm going to close this as a dup; if 4.8 does not fix the issue for you, feel free to re-open.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 475849 ***

Note You need to log in before you can comment on or make changes to this bug.