Bug 456676 - New Firefox 3.x has bad / missing NSS dependencies.
New Firefox 3.x has bad / missing NSS dependencies.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.7
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Kai Engert (:kaie)
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 10:32 EDT by paul boin
Modified: 2008-07-25 14:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 14:57:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paul boin 2008-07-25 10:32:47 EDT
Description of problem:

New Firefox 3.0.1 package, which is much appreciated, has bad dependencies.

$ firefox
/usr/lib64/firefox-3.0.1/firefox-bin: /usr/lib64/libnss3.so: version
`NSS_3.11.7' not found (required by /usr/lib64/firefox-3.0.1/libxul.so)
/usr/lib64/firefox-3.0.1/firefox-bin: /usr/lib64/libnss3.so: version `NSS_3.12'
not found (required by /usr/lib64/firefox-3.0.1/libxul.so


Version-Release number of selected component (if applicable):

sh-3.00# rpm -q firefox
firefox-3.0.1-1.el

howie:~ $ rpm -qf /usr/lib64/libnss3.so
nss-3.11.99.5-3.el4

How reproducible:

Should exist in any currently patched RHEL 4.7.

Steps to Reproduce:
1.  Try to run firefox.
2.  Get NSS version-not-found.
3.  Profit!
Comment 1 paul boin 2008-07-25 10:38:29 EDT
This appears to have come in yesterday on RHBA-2008:0704.
Comment 2 paul boin 2008-07-25 10:48:36 EDT
Strike that.  RHBA-2008:0704 is *not* the one, RHBA-2008:0664 is.
Comment 3 paul boin 2008-07-25 10:52:18 EDT
RHBA-2008:0783 has just been released this very moment.  It does not fix this
problem.
Comment 4 paul boin 2008-07-25 11:22:56 EDT
These commands appear to offer a fix, without new RH packages:

    rpm -e --nodeps nss.i386 nss.x86_64 firefox
    up2date -i nss firefox

Comment 5 paul boin 2008-07-25 14:32:22 EDT
Crap.  Looks like one of our guys had been re-compiling NSS so that 
SmartCard/CAC would be back-fitted to RHEL4.

Almost certainly our fault.

Please change to 'NOTABUG'.
Comment 6 Kai Engert (:kaie) 2008-07-25 14:57:21 EDT
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.