Bug 456688 - [T61] Poweroff when ultrabay battery is empty and internal battery full [NEEDINFO]
[T61] Poweroff when ultrabay battery is empty and internal battery full
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-power-manager (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 11:37 EDT by Alan Matsuoka
Modified: 2014-06-02 09:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (alanm)


Attachments (Terms of Use)
sosreport (670.12 KB, application/x-bzip2)
2008-07-25 11:37 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2008-07-25 11:37:47 EDT
On a Thinkpad T61 with one internal battery and on battery installed in the
Ultrabay docking station the ultrabay battery gets used first but after it's
empty the machine does not switch to the internal battery but powers down. This
only happens if a user is logged on to the machine, if not, it works just like
it should.

1. Provide time and date of the problem

persistent

2. Indicate the platform(s) (architectures) the problem is being reported against.

i386

3. Provide clear and concise problem description as it is understood at the time
of escalation
* Observed behavior

second battery does not get used if the first one is empty and a user is logged
on, system powers down instead.

* Desired behavior

system should switch to the second battery and not power down

4. State specific action requested of SEG

investigate further and fix the problem

5. State whether or not a defect in the product is suspected

customer suspects a bug in the gnome-power-manager, because if there is no user
logged on to the system the two batteries get used sequentially, just as it is
expected to work.

Provide supporting info

1. State other actions already taken in working the problem:

this is probably the same problem:

https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/60442
Comment 1 Alan Matsuoka 2008-07-25 11:37:48 EDT
Created attachment 312655 [details]
sosreport
Comment 2 RHEL Product and Program Management 2009-03-26 13:13:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 Alan Matsuoka 2009-03-26 13:22:54 EDT
setting for 5.5
Comment 4 Richard Hughes 2009-11-12 04:07:29 EST
I suspect I know the reason, but to be sure, could you please get the output of:

killall gnome-power-manager
gnome-power-manager --verbose

and try to get logs when the first battery is flat and the machine is suspending.

I suspect your T61 is doing the same thing as mine (and what we've just fixed in F12) in that:

* battery 1: fully charged
* battery 2: fully charged
* battery 1: discharging
* battery 1: nearly empty
* battery 1: empty, critical (battery 2 still fully charged)
* battery 2: unknown <--- this is when g-p-m freaks out.
* battery 2: discharging...

Thanks.
Comment 6 RHEL Product and Program Management 2014-03-07 08:38:25 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:06:41 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.