Bug 456689 - new sound theme problems
new sound theme problems
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 11:48 EDT by Matthias Clasen
Modified: 2008-07-28 09:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-27 19:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-07-25 11:48:17 EDT
The treeview for customizing theme sounds has some issues:

- A number of rows don't react at all to click or double click, such as
  "Audible Bell" and everything under "Windows and Buttons"

- The other pop up a combo on click. The 'custom' selection just pops up 
  a file chooser. 
  When I select a custom sound, it does show up in the treeview, but the next
  click pops up the combo again and there is no way to retain the previously
  selected sound. Frustrating !

- I've not been able to get sounds to play on double-click


My recommendations:

1) Make the customization work in all rows

2) Make the filechooser start out in /usr/share/sounds, currently it just
  seems to add a bookmark to that location. 

3) A more complicated (but cool) polish thing ould be to have audible preview
   in the file chooser.

4) Steal the little cell renderer hack from nautilus with which is now displays
   eject buttons for mounted volumes in the sidebar, and use it for a play
   button.
Comment 1 Matthias Clasen 2008-07-25 12:13:40 EDT
Also noticed in passing in .xsession-errors while playing with the bell settings:

Window manager warning: GConf key '/apps/metacity/general/visual_bell_type' is
set to an invalid value

Comment 2 Bastien Nocera 2008-07-25 12:25:35 EDT
(In reply to comment #0)
> The treeview for customizing theme sounds has some issues:
> 
> - A number of rows don't react at all to click or double click, such as
>   "Audible Bell" and everything under "Windows and Buttons"

We don't show well which sound rows are disabled right now. Those don't work
because you have "input feedback sounds" and "audible bell" disabled.

> - The other pop up a combo on click. The 'custom' selection just pops up 
>   a file chooser. 
>   When I select a custom sound, it does show up in the treeview, but the next
>   click pops up the combo again and there is no way to retain the previously
>   selected sound. Frustrating !

Cancelling the file chooser doesn't work? It should, easy to fix.

> - I've not been able to get sounds to play on double-click

I blame Lennart (you need the latest libgnome and gnome-settings-daemon
installed, and it should work). I'll test it out on my machine when it's a bit
rebased as well.

> My recommendations:
> 
> 1) Make the customization work in all rows

Actually, show better that the rows are supposed to be disabled.

> 2) Make the filechooser start out in /usr/share/sounds, currently it just
>   seems to add a bookmark to that location. 

Fair enough.

> 3) A more complicated (but cool) polish thing ould be to have audible preview
>    in the file chooser.

That should be pretty straight forward actually, if libcanberra allows that.

> 4) Steal the little cell renderer hack from nautilus with which is now displays
>    eject buttons for mounted volumes in the sidebar, and use it for a play
>    button.

Agreed.

(In reply to comment #1)
> Also noticed in passing in .xsession-errors while playing with the bell settings:
> 
> Window manager warning: GConf key '/apps/metacity/general/visual_bell_type' is
> set to an invalid value

That's metacity complaining. Which value is it set to? I think we set it to be
empty when the visual bell is disabled...
Comment 3 Matthias Clasen 2008-07-25 12:53:11 EDT
(In reply to comment #2)
> (In reply to comment #0)
> > The treeview for customizing theme sounds has some issues:
> > 
> > - A number of rows don't react at all to click or double click, such as
> >   "Audible Bell" and everything under "Windows and Buttons"
> 
> We don't show well which sound rows are disabled right now. Those don't work
> because you have "input feedback sounds" and "audible bell" disabled.

Ah, indeed. Thats not obvious at all. Those rows should be insensitive.
I can tell you how to do that.

> > - The other pop up a combo on click. The 'custom' selection just pops up 
> >   a file chooser. 
> >   When I select a custom sound, it does show up in the treeview, but the next
> >   click pops up the combo again and there is no way to retain the previously
> >   selected sound. Frustrating !
> 
> Cancelling the file chooser doesn't work? It should, easy to fix.

I don't even get that far. The next click brings up the combo, and if I just let
go, the value snaps back to "Default". I think the best may be to have the
previously selected custom sound as a value in the combo.

> > My recommendations:
> > 
> > 1) Make the customization work in all rows
> 
> Actually, show better that the rows are supposed to be disabled.

The easiest way to achive that is to add a boolean column to the model and
map it to the "sensitive" property of the cell renderers. Then update the
boolean value as the checkbox is toggled.

> > 3) A more complicated (but cool) polish thing ould be to have audible preview
> >    in the file chooser.
> 
> That should be pretty straight forward actually, if libcanberra allows that.

You want to use the GtkFileChooser::update-preview signal for that.

> 
> (In reply to comment #1)
> > Also noticed in passing in .xsession-errors while playing with the bell
settings:
> > 
> > Window manager warning: GConf key '/apps/metacity/general/visual_bell_type' is
> > set to an invalid value
> 
> That's metacity complaining. Which value is it set to? I think we set it to be
> empty when the visual bell is disabled...
>

It seems metacity only allows 'fullscreen' and 'frame_flash' as values.

Comment 4 Bastien Nocera 2008-07-25 20:57:02 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #0)
> > > The treeview for customizing theme sounds has some issues:
> > > 
> > > - A number of rows don't react at all to click or double click, such as
> > >   "Audible Bell" and everything under "Windows and Buttons"
> > 
> > We don't show well which sound rows are disabled right now. Those don't work
> > because you have "input feedback sounds" and "audible bell" disabled.
> 
> Ah, indeed. Thats not obvious at all. Those rows should be insensitive.
> I can tell you how to do that.

Fixed.

> > > - The other pop up a combo on click. The 'custom' selection just pops up 
> > >   a file chooser. 
> > >   When I select a custom sound, it does show up in the treeview, but the next
> > >   click pops up the combo again and there is no way to retain the previously
> > >   selected sound. Frustrating !
> > 
> > Cancelling the file chooser doesn't work? It should, easy to fix.
> 
> I don't even get that far. The next click brings up the combo, and if I just let
> go, the value snaps back to "Default". I think the best may be to have the
> previously selected custom sound as a value in the combo.

You mean that it should show both "Custom..." and the last selected custom
sound? That'll be trickier, but I'll give it a spin.

> > > My recommendations:
> > > 
> > > 1) Make the customization work in all rows
> > 
> > Actually, show better that the rows are supposed to be disabled.
> 
> The easiest way to achive that is to add a boolean column to the model and
> map it to the "sensitive" property of the cell renderers. Then update the
> boolean value as the checkbox is toggled.

Sigh. 3 lines of difference or something. I thought I would have to spin my own
pango markup, and I really wasn't looking forward to that... I guess I should
file a bug somewhere about the documentation.

> > > 3) A more complicated (but cool) polish thing ould be to have audible preview
> > >    in the file chooser.
> > 
> > That should be pretty straight forward actually, if libcanberra allows that.
> 
> You want to use the GtkFileChooser::update-preview signal for that.

Will fix.

> > (In reply to comment #1)
> > > Also noticed in passing in .xsession-errors while playing with the bell
> settings:
> > > 
> > > Window manager warning: GConf key '/apps/metacity/general/visual_bell_type' is
> > > set to an invalid value
> > 
> > That's metacity complaining. Which value is it set to? I think we set it to be
> > empty when the visual bell is disabled...
> >
> 
> It seems metacity only allows 'fullscreen' and 'frame_flash' as values.

Fixed.
Comment 5 Bastien Nocera 2008-07-27 19:40:10 EDT
A few of those problems are now fixed upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=542979

But still a few problems left:
http://bugzilla.gnome.org/show_bug.cgi?id=545056
http://bugzilla.gnome.org/show_bug.cgi?id=545055

I'll leave those to fix upstream.

Note You need to log in before you can comment on or make changes to this bug.