Bug 456691 - possible iwl4965 regression in 2.6.25.10-86
possible iwl4965 regression in 2.6.25.10-86
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 12:09 EDT by Phil Mayers
Modified: 2008-08-20 07:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 14:49:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
extract of /var/log/messages whilst failing with newer kernel (4.75 KB, application/x-gzip)
2008-07-25 12:12 EDT, Phil Mayers
no flags Details

  None (edit)
Description Phil Mayers 2008-07-25 12:09:28 EDT
Description of problem:

I have problems connecting to our WPA-Enterprise network (WPA, PEAP/MSCHAP)
under 2.6.25.10-86

If I reboot into the older kernel 2.6.25.9-76 I can connect fine

Driver is iwl4965, firmware version is 4.44.1.20-1

Version-Release number of selected component (if applicable):

2.6.25.10-86

How reproducible:

More or less always

Steps to Reproduce:
1. Try to connect to a WPA-enterprise network
2. System just prompts for password repeatedly
3. Never connects
  
Actual results:

No wireless

Expected results:

Wireless

Additional info:

I seem to get errors in /var/log/messages including:

iwl4965: Error sending TX power (-22)

There are also kernel oopses (info to follow in an attachment)

Our wireless platform (Cisco lightweight, formerly Airespace) syslogs messages
when I'm using the broken kernel version:

APF-3-CHECK_EXT_SUPP_RATES_FAILED: Could not check extended supported rates.
Missing supported rate for station. Length :0. Mobile MAC: 00:13:e8:c1:f8:f9.

APF-1-CONFLICT_IN_ASS_REQ: Conflicting Supported Rates in Association Request
from00:13:e8:c1:f8:f9
Comment 1 Phil Mayers 2008-07-25 12:12:39 EDT
Created attachment 312658 [details]
extract of /var/log/messages whilst failing with newer kernel
Comment 2 John W. Linville 2008-07-31 13:35:37 EDT
Can you try -97?  Someone else reported that it resolved this issue.
Comment 3 John W. Linville 2008-08-19 14:49:59 EDT
Closed due to lack of response...I'm pretty sure this is fixed.
Comment 4 Phil Mayers 2008-08-20 07:35:22 EDT
Yes, sorry for not replying - for reference, the -97 update did indeed correct the problem

Note You need to log in before you can comment on or make changes to this bug.