Bug 456708 - BuildRoot doesn't honor %_topdir
BuildRoot doesn't honor %_topdir
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 14:12 EDT by Jonathan Kamens
Modified: 2008-08-04 02:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.5.90-0.git8444.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 02:47:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-07-25 14:12:44 EDT
It appears that, in rpm-build-4.5.90-0.git8426.9.i386, the "BuildRoot:" setting 
in spec files is being ignored.
Comment 1 Panu Matilainen 2008-07-25 15:45:56 EDT
The buildroot in specfiles is ignored on purpose, NOTABUG.

If a package depends on an exact buildroot, basically the package is buggy, but
since historically rpm has honored spec provided buildroot the new behavior is
certain to "break" a bunch of packages. Just curious: what's the scenario in
your case that "requires" a specific buildroot?
Comment 2 Jonathan Kamens 2008-07-25 15:52:37 EDT
I have always built in /usr/src/redhat.  When y'all changed the default to 
build in ~/rpmbuild, I redefined _topdir to /usr/src/redhat in my ~/.rpmmacros 
file to put back the default, but that doesn't change buildrootdir, hence I 
noticed the problem (since it tried to use ~/buildroot/BUILDROOT, which doesn't 
exist).
Comment 3 Panu Matilainen 2008-07-25 16:33:34 EDT
Right, in that case there is an actual bug involved: while the spec buildroot is
ignored on purpose, the default buildroot should follow _topdir unless
specifically overridden.
Comment 4 Panu Matilainen 2008-07-26 04:05:00 EDT
Fixed upstream
Comment 5 Panu Matilainen 2008-08-04 02:47:13 EDT
Fixed by rpm-4.5.90-0.git8444.1 in rawhide

Note You need to log in before you can comment on or make changes to this bug.