Bug 456721 - Grip silently crahses on F8
Grip silently crahses on F8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 16:00 EDT by Gian Paolo Mureddu
Modified: 2008-11-10 01:40 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 01:40:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of grip (172.58 KB, text/plain)
2008-07-25 16:00 EDT, Gian Paolo Mureddu
no flags Details

  None (edit)
Description Gian Paolo Mureddu 2008-07-25 16:00:57 EDT
Description of problem:
Grip fails to start and crashes on Fedora 8

Version-Release number of selected component (if applicable):
3.2.0-19.fc8x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install grip with yum on an x86_64 system
2. Try to run it from command line
3.
  
Actual results:
Grip crashes, no message on the command line

Expected results:
Grip to properly launch

Additional info:
Attached is the trace of running grip through strace -o grip
Comment 1 Gian Paolo Mureddu 2008-07-25 16:00:57 EDT
Created attachment 312677 [details]
Strace of grip
Comment 2 Gian Paolo Mureddu 2008-07-25 16:06:46 EDT
Currently in the process of running it through GDB, but apparently there are LOT
of debuginfo dependencies to trouble-shoot this crash. Debuginfo-install pulled
all these dependencies:

 GConf2-debuginfo        x86_64     2.20.1-1.fc8     fedora-debuginfo  577 k
 ORBit2-debuginfo        x86_64     2.14.10-2.fc8    fedora-debuginfo  856 k
 atk-debuginfo           x86_64     1.20.0-1.fc8     fedora-debuginfo  180 k
 cairo-debuginfo         x86_64     1.4.14-1.fc8     updates-debuginfo  1.0 M
 cdparanoia-debuginfo    x86_64     alpha9.8-27.2    fedora-debuginfo  116 k
 curl-debuginfo          x86_64     7.18.2-1.fc8     updates-debuginfo  859 k
 fontconfig-debuginfo    x86_64     2.4.2-5.fc8      fedora-debuginfo  329 k
 freetype-debuginfo      x86_64     2.3.5-4.fc8      updates-debuginfo  2.0 M
 freetype-freeworld-debuginfo  x86_64     2.3.5-4.lvn8     livna-debuginfo   1.4 M
 glib2-debuginfo         x86_64     2.14.6-2.fc8     updates-debuginfo  1.5 M
 glibc-debuginfo         x86_64     2.7-2            fedora-debuginfo   20 M
 gnome-vfs2-debuginfo    x86_64     2.20.1-1.fc8     updates-debuginfo  1.5 M
 gtk2-debuginfo          x86_64     2.12.8-2.fc8     updates-debuginfo  7.0 M
 id3lib-debuginfo        x86_64     3.8.3-17.fc8     fedora-debuginfo  756 k
 libICE-debuginfo        x86_64     1.0.4-2.fc8      fedora-debuginfo  131 k
 libSM-debuginfo         x86_64     1.0.2-4.fc8      fedora-debuginfo   55 k
 libX11-debuginfo        x86_64     1.1.3-4.fc8      fedora-debuginfo  3.7 M
 libXft-debuginfo        x86_64     2.1.12-3.fc8     fedora-debuginfo  210 k
 libXrender-debuginfo    x86_64     0.9.4-1.fc8      fedora-debuginfo  144 k
 libart_lgpl-debuginfo   x86_64     2.3.19-3.fc8     fedora-debuginfo  172 k
 libbonobo-debuginfo     x86_64     2.20.3-1.fc8     updates-debuginfo  867 k
 libbonoboui-debuginfo   x86_64     2.20.0-1.fc8     fedora-debuginfo  841 k
 libgnome-debuginfo      x86_64     2.20.1-2.fc8     fedora-debuginfo  166 k
 libgnomecanvas-debuginfo  x86_64     2.20.1-1.fc8     fedora-debuginfo  342 k
 libgnomeui-debuginfo    x86_64     2.20.1.1-1.fc8   fedora-debuginfo  1.0 M
 pango-debuginfo         x86_64     1.18.4-1.fc8     updates-debuginfo  1.2 M
 popt-debuginfo          x86_64     1.13-4.fc8       updates-debuginfo   59 k
 vte-debuginfo           x86_64     0.16.9-1.fc8     fedora-debuginfo  691 k
 zlib-debuginfo          x86_64     1.2.3-14.fc8     fedora-debuginfo  211 k
Updating:
 grip-debuginfo          x86_64     1:3.2.0-19.fc8   updates-debuginfo  204 k
Installing for dependencies:
 minizip                 x86_64     1.2.3-14.fc8     fedora             23 k
Comment 3 Gian Paolo Mureddu 2008-07-25 16:17:26 EDT
This must be a joke... I'll end up installing debuginfo-Everything! GDB
complains with:

Missing separate debuginfos, use: debuginfo-install alsa-lib.x86_64
audiofile.x86_64 avahi.x86_64 bug-buddy.x86_64 dbus-glib.x86_64 dbus.x86_64
e2fsprogs.x86_64 elfutils.x86_64 esound.x86_64 expat.x86_64 gail.x86_64
gcc.x86_64 gnome-keyring.x86_64 gtk2-engines.x86_64 keyutils.x86_64 krb5.x86_64
libXau.x86_64 libXcomposite.x86_64 libXcursor.x86_64 libXdmcp.x86_64
libXext.x86_64 libXfixes.x86_64 libXi.x86_64 libXinerama.x86_64 libXrandr.x86_64
libcap.x86_64 libidn.x86_64 libjpeg.x86_64 libpng.x86_64 libselinux.x86_64
libxcb.x86_64 libxml2.x86_64 ncurses.x86_64 nspr.x86_64 nss.x86_64 openssl.x86_64
Comment 4 Adrian Reber 2008-07-25 16:26:34 EDT
If it is a bug in grip grip-debuginfo should be enough to see where it is
crashing. If it is crashing somewhere else it is probably not a grip bug.

Which locale are you using? Can you try with "LANG=C grip"?

I have no x86_64 machine to test. So I can unfortunately not reproduce this error.
Comment 5 Gian Paolo Mureddu 2008-07-25 16:31:43 EDT
Seems I won't be able to do this on my own... GDB complained about these other
deps, Missing separate debuginfos, use: debuginfo-install esound.x86_64
gcc.x86_64 keyutils.x86_64, however that yields, after a lot of screen scrolling:

Could not find debuginfo for main pkg: gcc - 4.3.0-8.x86_64
Package glibc-debuginfo - 2.7-2.x86_64 already installed and latest version
Package glibc-debuginfo - 2.7-2.x86_64 already installed and latest version
Package glibc-debuginfo - 2.7-2.x86_64 already installed and latest version
Package glibc-debuginfo - 2.7-2.x86_64 already installed and latest version
Could not find debuginfo pkg for dependency package libgcc - 4.3.0-8.x86_64
Could not find debuginfo pkg for dependency package libgomp - 4.3.0-8.x86_64
No debuginfo packages available to install.
Comment 6 Gian Paolo Mureddu 2008-07-25 16:34:12 EDT
Adrian, I am using es-MX locale will try to launch with LANG=C and see what
happens... Ok, so it seems that Grip doesn't like UTF8 locales, or some such?
Should this be added to the exec line of the .desktop?
Comment 7 Adrian Reber 2008-07-25 16:58:17 EDT
Okay, I can reproduce it with F-9 on i386 if I start it with: 

LANG=es_MX.UTF-8  grip

If I convert the es.po file to utf8 before compiling it to es.gmo it does not
crash. The easy fix seems to be to convert all po files which are not utf8 to
utf8 and it should work.
Comment 8 Fedora Update System 2008-07-27 15:22:50 EDT
grip-3.2.0-20.fc9 has been submitted as an update for Fedora 9
Comment 9 Fedora Update System 2008-07-27 15:23:52 EDT
grip-3.2.0-20.fc8 has been submitted as an update for Fedora 8
Comment 10 Fedora Update System 2008-07-30 16:06:29 EDT
grip-3.2.0-20.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update grip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6836
Comment 11 Gian Paolo Mureddu 2008-07-30 16:15:19 EDT
I will test on both my systems (F8 and F9). I don't see it as an update for F8
yet, though.
Comment 12 Fedora Update System 2008-08-07 19:51:37 EDT
grip-3.2.0-20.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-08-07 19:59:02 EDT
grip-3.2.0-20.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Adrian Reber 2008-11-10 01:39:59 EST
Closing it. The fixed version has been already released a few months ago.

Note You need to log in before you can comment on or make changes to this bug.