This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 456761 - API files in %{_libdir}
API files in %{_libdir}
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qscintilla (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-26 13:04 EDT by Johan Cwiklinski
Modified: 2008-08-15 11:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-15 11:30:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Cwiklinski 2008-07-26 13:04:02 EDT
It seems that *.api files from qscintilla are now installed under %{_libdir}
(under rawhide), instead of %{_datadir} (F-9).

I'm packaging eric, which is a noarch package, and which install its own api
files. Of course, under rawhide, it uses %{_libdir}/qt4/qsci/api/python/ ; wich
is not correct for a noarch package.

Since *.api files are not arch dependant, I think it should not being installed
under %{_libdir}, right ?

Regards,
Johan
Comment 1 Rex Dieter 2008-07-26 14:35:07 EDT
Problem being is we found out not too long ago that qt4's notion of %_datadir
wasn't exactly arch-independent.  Workarounds failed.  So, ended up moving
%_qt4_datadir from %_datadir/qt4 to %{_libdir}/qt4, and this is the result.

Options include:
1.  Manually moving qscintilla api files to %_datadir/qt4 .  This may have
unforseen breakage.  What else uses (or can use) these .api files?
or
2.  teach eric to look in both %_datadir/qt4 and %_libdir/qt4 for api files

opinions?
Comment 2 Johan Cwiklinski 2008-07-26 15:15:24 EDT
Hum...

I really don't know what would be the better solution. At eric installs, it
defaults to 'pyqtconfig._pkg_config["qt_data_dir"]'. qt_data_dir is not used
elsewhere in eric's sources (according to grep).
I'll try to investigate to find out how these files are used at runtime, so
maybe can I patch it to look into both %_datadir and %_libdir (32 and 64bits).

I really don't know what could use .api files, moving them should not be ok
since 'pyqtconfig._pkg_config["qt_data_dir"]' will always return %_libdir :/
Comment 3 Johan Cwiklinski 2008-08-15 07:21:54 EDT
I've asked upstream, answer is here : http://www.riverbankcomputing.com/pipermail/eric/2008-August/001189.html

I really do not know what to do ; It is really too much complicated for me, sorry.
Comment 4 Rex Dieter 2008-08-15 08:46:12 EDT
Shrug, maybe simplest solution is to simply make eric an arch pkg (no longer noarch), and then stuff would end up in the right place.
Comment 5 Johan Cwiklinski 2008-08-15 10:32:40 EDT
I've taken a look at this possibility already, but this makes rpmlint unhappy (E: no-binary and E: only-non-binary-in-usr-lib).

Do you think that these rpmlint errors should be ignored ? If so, I'll remove the 'BuildArch: noarch' tag from future versions.
Comment 6 Rex Dieter 2008-08-15 10:40:54 EDT
rpmlint warnings vs.  app not working.

I'll take the former as the lesser of 2 evils here. ;)
Comment 7 Johan Cwiklinski 2008-08-15 11:30:14 EDT
:-) 

Okay,thanks for the advices and the help, I'll push the new versions into rawhide and updates-testing soon.

Note You need to log in before you can comment on or make changes to this bug.