Bug 456790 - Wine-1.1.2 willl not compile -- bad `/usr/local/src/WINE/wine-1.1.2/dlls/user32/tests/menu.c file
Wine-1.1.2 willl not compile -- bad `/usr/local/src/WINE/wine-1.1.2/dlls/user...
Status: CLOSED DUPLICATE of bug 440139
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 00:55 EDT by Sam'l Bassett
Modified: 2008-10-20 02:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 02:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam'l Bassett 2008-07-27 00:55:20 EDT
Description of problem:

make[2]: Entering directory `/usr/local/src/WINE/wine-1.1.2/dlls/user32/tests'
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7419: Warning: end of file not at end of a line; newline inserted
{standard input}:7752: Error: no such instruction: `m'
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.

Version-Release number of selected component (if applicable):

wine-1.1.2  (Downloaded today from SourceForge.net)

How reproducible:

Every time I try to run make

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Error quoted above

Expected results:

Compile wine

Additional info:
Comment 1 Jim 2008-08-23 14:24:50 EDT
From bug report 445494:
"Comment #5 From  Marcus Meissner  2008-05-21 16:50:35 EDT  -------

it is a out of stack space problem. there are gcc bugs already, and it is 
fixed in 4.3 branch

ulimit -s unlimited"

I have gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) and the problem still shows up.  When I entered the ulimit command before compiling, the error went away so I have my doubts the gcc problem is "fixed" in the currently available 4.3 branch.
Comment 2 Jonathan Blandford 2008-09-05 14:43:30 EDT
Reassigning to default owner.
Comment 3 Dan Williams 2008-09-05 14:47:22 EDT
-> fedora/gcc
Comment 4 Jakub Jelinek 2008-10-20 02:33:28 EDT

*** This bug has been marked as a duplicate of bug 440139 ***

Note You need to log in before you can comment on or make changes to this bug.