Bug 456811 - fix concurrency timeout handling
fix concurrency timeout handling
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libusb (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-07-27 11:50 EDT by Nicolas Mailhot
Modified: 2013-07-02 19:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 07:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-07-27 11:50:48 EDT
Please merge this patch
http://svn.mandriva.com/svn/packages/cooker/libusb/current/SOURCES/libusb-0.1.12-concurrency-timeout.patch

credited to Graeme Gill (argyllcms)

and discussed there
http://www.freelists.org/archives/argyllcms/07-2008/msg00233.html

(even better if you can push it upstream)

It's needed to support some colorimeter devices and Graeme Gill insists our
version of Argyll is broken without it
Comment 1 Jindrich Novy 2008-08-02 02:51:56 EDT
The patch is now applied, thanks for noticing. I'm unable to build the new
libusb though due to docbook breakage:

http://koji.fedoraproject.org/koji/getfile?taskID=753932&name=build.log
Comment 2 Jesse Keating 2008-10-03 19:42:22 EDT
This now rebuilds successfully.  Closing -> RAWHIDE.
Comment 3 James Ralston 2008-10-11 00:51:23 EDT
Unfortunately, this patch breaks the ability of pilot-link to sync with Palm TX devices (and possibly other devices as well).

I've filed bug 466602 against pilot-link (in order to pull in the upstream pilot-link developers), but for the now, could you please back out this patch?
Comment 4 Jindrich Novy 2008-10-14 07:03:00 EDT
Ok, the patch is now reverted.

Note You need to log in before you can comment on or make changes to this bug.