Bug 456823 - new-kernel-pkg aborted while updating to kernel 2.6.25.11-97
new-kernel-pkg aborted while updating to kernel 2.6.25.11-97
Status: CLOSED DUPLICATE of bug 440661
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 16:06 EDT by regis.fouret
Modified: 2014-01-21 18:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 12:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from yum (29.57 KB, text/plain)
2008-07-27 16:06 EDT, regis.fouret
no flags Details

  None (edit)
Description regis.fouret 2008-07-27 16:06:44 EDT
Description of problem:
yum -y install  kernel-2.6.25.11-97.fc9.i686 results in 

/sbin/new-kernel-pkg: line 104: 19259 Aborted ...
Installed: kernel.i686 0:2.6.25.11-97.fc9
Complete!

see the complete output of yum in the attachment


I can't boot from this kernel after having edited grub.conf with the new vmlinuz
and initrd, it says something like there is a problem with /dev/root, my root
filesystem isn't even mounted...

Version-Release number of selected component (if applicable):


How reproducible:
always
  
Expected results:
how about my grub.conf being edited normally, and my kernel being bootable? ;)
is there a problem with my UUID of my root filesystem?? ...
Comment 1 regis.fouret 2008-07-27 16:06:44 EDT
Created attachment 312744 [details]
output from yum
Comment 2 Bruce Brackbill 2008-07-27 16:36:27 EDT
This bug looks similar to:

https://bugzilla.redhat.com/show_bug.cgi?id=440661
Comment 3 regis.fouret 2008-07-27 18:35:36 EDT
Well thanks!! i tried to unmount my usb drives, rmmoded usb_storage , removed
11-97 kernel,reinstalled 11-97 and it worked ok :)

I did not find this bug while searching...

You can mark it as a duplicate of this bug!

Here's some more information if that can help:

After the broken installation of 11-97 kernel, i tried to boot with it and
here's what i got:

mount: could not find filesystem /dev/root
setuproot: moving /dev failed: no such file or directory
setuproot: error mounting /proc: no such file or directory
setuproot: error mounting /sys: no such file or directory
mount failed for selinuxfs on /selinux
switchroot: mount failed
hub 1-0:1.0: unable to enumerate USB device on port 2

and then it stopped, i could reboot with ctrl-alt-sup.

So it's rather strange considering vmlinuz, initrd, and config files for the
kernel 11-97 were in place in /boot ... i just modified grub.conf in order to
boot with the 11-97 kernel and 11-97 initrd and apparently it could not mount my
root filesystem or something...
I thought the yum install of 11-97 kernel had installed the files correctly
while failing to change grub.conf only but apparently there was something else
that failed? ...

I should add that i already had kernel updates with my fedora 9, with
usb_storage loaded and many usb hard drives mounted and it just worked
perfectly, anyhow this time it failed...

ok at least 2 guys encountered this weird bug ;)
Comment 4 James Antill 2008-08-12 12:47:55 EDT

*** This bug has been marked as a duplicate of bug 440661 ***

Note You need to log in before you can comment on or make changes to this bug.