Bug 456843 - Erroneous unversioned-explicit-obsoletes inside macro def
Erroneous unversioned-explicit-obsoletes inside macro def
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 22:32 EDT by Sean Flanigan
Modified: 2008-11-22 11:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 06:25:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example spec file which produces unversioned-explicit-obsoletes warning (3.41 KB, application/octet-stream)
2008-07-27 22:33 EDT, Sean Flanigan
no flags Details

  None (edit)
Description Sean Flanigan 2008-07-27 22:32:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
rpmlint seems to be giving an invalid unversioned-explicit-obsoletes warning on my spec file.

Version-Release number of selected component (if applicable):
rpmlint-0.83-1.fc9.noarch

How reproducible:
Always


Steps to Reproduce:
1.rpmlint eclipse-nls.spec


Actual Results:
I got the error "eclipse-nls.spec:36: W: unversioned-explicit-obsoletes \"

Expected Results:
No error message, at least for that line of the spec file.

Additional info:
The spec file line in question does contain a version:

Obsoletes:  eclipse-sdk-nls-%1 <= 3.2.1 \

The backslash at the end is there because this is part of a multi-line macro definition.  See the attachment.
Comment 1 Sean Flanigan 2008-07-27 22:33:59 EDT
Created attachment 312747 [details]
Example spec file which produces unversioned-explicit-obsoletes warning
Comment 2 Ville Skyttä 2008-07-30 12:50:16 EDT
rpmlint probably has quite a few other potential issues with multiline macro
definitions, but I put a hack for this specific case upstream; this will
probably be in the next upstream post 0.84 release: 
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1447
Comment 3 Fedora Update System 2008-10-23 16:54:18 EDT
rpmlint-0.85-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/rpmlint-0.85-1.fc9
Comment 4 Fedora Update System 2008-10-24 19:49:27 EDT
rpmlint-0.85-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9125
Comment 5 Sean Flanigan 2008-10-26 20:02:49 EDT
Looks good to me.
Comment 6 Fedora Update System 2008-10-31 06:25:02 EDT
rpmlint-0.85-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-11-04 12:37:05 EST
rpmlint-0.85-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmlint-0.85-2.fc10
Comment 8 Fedora Update System 2008-11-22 11:55:31 EST
rpmlint-0.85-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.