Bug 456857 - dkms remove seems to affect proper kernel uninstall
dkms remove seems to affect proper kernel uninstall
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 04:14 EDT by Piergiorgio Sartor
Modified: 2009-04-01 17:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 08:19:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2008-07-28 04:14:15 EDT
Description of problem:
With the new hooks for dkms, the kernel pre-remove/uninstall calls "dkms remove
..." (or whatever) in order to remove the (old) dkms modules.
It seems that, maybe due to the depmod, the kernel uninstall procedure does not
cleanup completely the /lib/modules/'kernel'/

Version-Release number of selected component (if applicable):
dkms-2.0.19.1-1.fc9.noarch

How reproducible:
It seems always, on kernel upgrade

Steps to Reproduce:
1.
Having some dkms modules, like nvidia

2.
yum upgrade [kernel], when new kernel is available and with two alread (old)
kernel installed
  
Actual results:
The /lib/modules/'old kernel' directory is not removed and it contains, after
uninstall, still some depmod files.
That is, "ls /lib/modules/'old kernel'" returns:

modules.alias   modules.ieee1394map  modules.ofmap     modules.symbols
modules.ccwmap  modules.inputmap     modules.pcimap    modules.usbmap
modules.dep     modules.isapnpmap    modules.seriomap

These files all have the date and time when the upgrade/uninstall occurred.

Expected results:
Well, nothing should be left over.

Additional info:
This *might* be a kernel related bug, but since the kernel bug list is very
crowded, maybe better to start from dkms... ;-)
Comment 1 Matt Domsch 2008-08-06 17:22:31 EDT
I believe this is because the kernel packages does not own all of  the /lib/modules/$kernelver/modules.* files which depmod may now create.

modules.alias
modules.block
modules.ccwmap
modules.dep
modules.ieee1394map
modules.inputmap
modules.isapnpmap
modules.networking
modules.ofmap
modules.order
modules.pcimap
modules.seriomap
modules.symbols
modules.usbmap

Of these, the spec only includes 3 in  kernel_variant_files:
/lib/modules/%{KVERREL}%{?2:.%{2}}/modules.block\
/lib/modules/%{KVERREL}%{?2:.%{2}}/modules.networking\
/lib/modules/%{KVERREL}%{?2:.%{2}}/modules.order\

and it owns the directory /lib/modules/${KVERREL...} separately.

I suspect the change to the kernel spec would be to replace the three modules.{block,networking,order} lines with a modules.* line to pick up them all.
Comment 2 Dave Jones 2008-08-06 17:36:40 EDT
make sense.  Changed in CVS for F9/devel
Comment 3 Fedora Update System 2008-08-13 23:55:38 EDT
kernel-2.6.26.2-14.fc9 has been submitted as an update for Fedora 9.
/updates/kernel-2.6.26.2-14.fc9
Comment 4 Fedora Update System 2008-08-31 11:02:24 EDT
kernel-2.6.26.3-27.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-27.fc9
Comment 5 Fedora Update System 2008-09-03 12:49:28 EDT
kernel-2.6.26.3-29.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-29.fc9
Comment 6 Fedora Update System 2008-09-05 08:19:25 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-09-10 03:06:47 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.