Bug 456858 - [RFE] ip-sentinel configuration files and inclusion in EPEL
[RFE] ip-sentinel configuration files and inclusion in EPEL
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ip-sentinel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 04:15 EDT by Răzvan Sandu
Modified: 2009-09-13 07:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-13 07:39:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-07-28 04:15:12 EDT
Description of problem:

Hello,

IMHO, the ip-sentinel package should suffer the following two modifications, in
order to increase its quality and Red Hat scheme compliance:

1. The configuration file /var/lib/ip-sentinel/ips.cfg should be moved to
/etc/ip-sentinel/ips.cfg;

2. The configuration file /etc/sysconfig/ip-sentinel should contain the
following line *by default* (as installed by RPM package):

IPS_OPTIONS="--poison --mac 802.3x --direction BOTH"


Also, please consider including ip-sentinel into the EPEL repository, since *we
don't have an equivalent functionality* in CentOS or RHEL...


Version
ip-sentinel-0.12-10


Thanks a lot,
Răzvan
Comment 1 Enrico Scholz 2009-09-13 07:39:19 EDT
1. not a bug;  'ip-sentinel' runs in a /var/lib/ip-sentinel chroot and needs its configuration there

2. won't change; these options are assumed by default since 2004.  No need to specify them explicitly

As long as the used SCM does not allow easy cherry picking between branches I do not plan to contribute to EPEL.  I am not sure about politics and bureaucracy in EPEL either, so don't expect a branch request from me in the near future.

Note You need to log in before you can comment on or make changes to this bug.