Bug 456860 - Link is displaced
Link is displaced
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: elinks (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 04:25 EDT by Jaroslav Reznik
Modified: 2008-08-04 07:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 07:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (5.81 KB, image/png)
2008-07-28 04:25 EDT, Jaroslav Reznik
no flags Details

  None (edit)
Description Jaroslav Reznik 2008-07-28 04:25:16 EDT
Description of problem:
Links are displaced. Look at "Steps to Reproduce"

Version-Release number of selected component (if applicable): default Fedora 9
package (0.11)

How reproducible:
always

Steps to Reproduce:
1. elinks http://www.hofyland.cz/
2. now select some links (by arrow keys)
  
Actual results:
Links are displaced - see attached screenshot. When using mouse you have to
click a little aside.

Expected results:
Links are not mangled. Fixed in Rawhide (ver. 0.12pre1).

Additional info:
Comment 1 Jaroslav Reznik 2008-07-28 04:25:16 EDT
Created attachment 312757 [details]
Screenshot
Comment 2 Kamil Dudka 2008-07-30 11:30:27 EDT
This displacement is caused by UTF-8 characters in link's text. The same 
behavior can be seen on 0.12 branch of elinks with disabled UTF-8 support (./
configure --disable-utf-8). Unfortunately the 0.11 branch of elinks is not 
UTF-8 ready.

There is no easy way to backport UTF-8 support from rawhide. To work around 
this you can simply set "7-bit ASCII" character set from menu and links will be
displayed properly.
Comment 3 Kamil Dudka 2008-08-04 07:16:09 EDT
Solution for that issue is not easy. Simple backport is not possible. As workaround you can change character set to 7-bit ASCII.

Note You need to log in before you can comment on or make changes to this bug.