Bug 456878 - F10 Alpha (ppc) reducto .treeinfo missing data
F10 Alpha (ppc) reducto .treeinfo missing data
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 08:46 EDT by James Laska
Modified: 2013-09-02 02:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 10:30:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-07-28 08:46:13 EDT
Two issues noted with the F10-Alpha (ppc) compose on reducto
(http://reducto.install.bos.redhat.com/pungi/f10-alpha.0/10-Alpha/ppc/os)

1) Missing ppc64 netboot/ppc64.img

Inspecting .treeinfo shows ...

[images-ppc64]
initrd = ppc/ppc64/ramdisk.image.gz
zimage = images/netboot/ppc64.img
kernel = ppc/ppc64/vmlinuz

The zimage file listed is not present in the tree

However, the zimage is present in the public
http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/images/netboot
version.


2) iSeries boot.img missing from [images-ppc64] section

Additionally, the checksums section lists an iSeries boot.img 

[checksums]
...
/images/iseries/boot.img = 898fa108968df4887b1c7704028f2651889f662d

However, this file is not listed in the [images-ppc64] section as expected.

Issue #1 appears to be resolved in the current rawhide tree.  However, issue #2
does not appear to be resolved in current rawhide.
Comment 1 Jesse Keating 2008-07-28 15:32:18 EDT
These appear to both be anaconda issues.

1) some part of buildinstall + friends is still writing to the file that they're
generating a netboot.img, but then not actually creating it.

2) pungi just walks the tree to sha1 anything it finds, the fact that anaconda
doesn't write to the [images] section is it's fault.
Comment 2 Jesse Keating 2008-07-28 15:55:04 EDT
Looks like this is due to mk-images.* not actually verifying that the image file
was written out before A) continuing, and B) claiming that it was written by
referencing it in the .treeinfo file.

Some digging later it turns out that the call to make the netboot images show up
was actually failing due to a missing requires on 'gzip'.

That answers #1, not #2 yet.
Comment 3 Jesse Keating 2008-08-05 14:57:03 EDT
Ok, the ppc community has spoken, we can kill the iseries goo.  RHEL doesn't support it, there are seemingly no people using it in the community.  We no longer need to produce that content.
Comment 4 Chris Lumens 2008-08-06 13:55:50 EDT
David committed the iSeries removal yesterday, so this should be fixed in the next build of anaconda/rawhide.
Comment 5 James Laska 2008-11-06 10:29:47 EST
Verified in rawhide-20081106 .treeinfo

# curl http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/.treeinfo
[checksums]
ppc/efika.forth = sha1:ebd17f92d375dbfdaeaeef35125106e9d83c7bc3
images/netboot/ppc64.img = sha1:652cfafaf7f99d25b1e0d4726db4a43490181699
ppc/ppc64/yaboot.conf = sha1:e8c6ab0cfce63967efe372d2187967003a2eea62
ppc/ppc64/ramdisk.image.gz = sha1:a932b13ba1af83818b4ec213516b569e81d14c93
ppc/ppc32/yaboot.conf = sha1:56d09c1be8e31676629fb97a7a07a9f30f4d4e6c
ppc/mac/yaboot = sha1:bf61fecf6e6bbe98160e66616a2c7b117ceb4fec
images/boot.iso = sha1:45144c1bfcbaef8295d332c16987f38e374e7482
ppc/ppc32/ramdisk.image.gz = sha1:cfd20c6ad2fa179ac6459c83a136d387fd00f0d0
images/install.img = sha1:c423209cabb718889ea3d0e0a6b23d1c2e0733a1
ppc/bootinfo.txt = sha1:9536b3ae35f8d933736748fe2239ebbc9b7fa30a
ppc/mac/ofboot.b = sha1:0c4114b7913d93ea457976615d09c808158079de
repodata/repomd.xml = sha1:46ac17433a4726606f324d7e88dd5ec4266742d3
ppc/ppc64/vmlinuz = sha1:86854bca560370e8d7a9509a2ebf24f26cce35a6
ppc/ppc32/vmlinuz = sha1:feea7ac34c37192b2a03c39b420cb1f28e6ca345
images/netboot/ppc32.img = sha1:4d61c7a0ab3f15dae2fec17690d4b4f62a68eb23
ppc/chrp/yaboot = sha1:76a27461efe9dc426236266cd8d381a16e36d132

[images-ppc]
initrd = ppc/ppc32/ramdisk.image.gz
zimage = images/netboot/ppc32.img
kernel = ppc/ppc32/vmlinuz

[stage2]
mainimage = images/install.img

[images-ppc64]
initrd = ppc/ppc64/ramdisk.image.gz
zimage = images/netboot/ppc64.img
kernel = ppc/ppc64/vmlinuz

[general]
family = Fedora
timestamp = 1225966686.05
variant = 
totaldiscs = 1
version = development
discnum = 1
packagedir = 
arch = ppc

Note You need to log in before you can comment on or make changes to this bug.