Bug 456895 - Include pacemaker in Red Hat Enterprise Linux 6
Include pacemaker in Red Hat Enterprise Linux 6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Andrew Beekhof
Cluster QE
: FutureFeature, Reopened, TechPreview
: 493474 (view as bug list)
Depends On: 303171 456897
Blocks: 310361 449833 449835 451848
  Show dependency treegraph
 
Reported: 2008-07-28 10:39 EDT by Lon Hohberger
Modified: 2016-04-26 09:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Pacemaker, a scalable high-availability cluster resource manager, is included in Red Hat Enterprise Linux 6 as a Technology Preview. Pacemaker is not fully integrated with the Red Hat cluster stack.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:21:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2008-07-28 10:39:29 EDT
Description of problem:

Pacemaker is effectively a superset of what rgmanager can do.

http://clusterlabs.org/

Some of the requested features of rgmanager which are already features of Pacemaker:
 * Resource-dependency model instead of service model (upgrade path required)
 * Time-based resource control (bug #310361)
 * Per-resource restart counters (bug #449833)
 * Disable monitoring of specific resources (bug #449835)
 * Promote/demote/alternate behaviors (bug #451848)
Comment 1 Lon Hohberger 2008-07-28 10:51:17 EDT
This bug depends on a way to preserve rolling upgrade:

1. bug #303171 - we must be able to stop rgmanager in RHEL5 without stopping
services, so that when we start pacemaker, it can just "take over" running services
2. bug #456897 - we must be able to provide customers with an upgrade path for
their rgmanager configuration
Comment 4 Siddharth Nagar 2009-06-04 16:46:49 EDT
*** Bug 493474 has been marked as a duplicate of this bug. ***
Comment 7 Perry Myers 2009-10-01 10:11:30 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Pacemaker component in RHEL6.0 is TechPreview.  It is not fully integrated with the Red Hat cluster stack, but can be used as a standalone component for managing highly available services.
Comment 10 Ryan Lerch 2010-05-20 23:10:46 EDT
Technical note updated. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-Pacemaker component in RHEL6.0 is TechPreview.  It is not fully integrated with the Red Hat cluster stack, but can be used as a standalone component for managing highly available services.+Pacemaker, a scalable high-availability cluster resource manager, is included in Red Hat Enterprise Linux 6 as a Technology Preview. Pacemaker is not fully integrated with the Red Hat cluster stack.
Comment 11 Nate Straz 2010-06-25 16:35:18 EDT
The packages are included, but I have no idea what is needed to verify that everything that needs to be included IS included.  I could use some direction from development.

A quick look at the packages I noticed that there isn't an init script, nor a "pacemaker" man page.

Since this is a tech-preview package I expect that verifying the package is included and complete is enough to satisfy this bug.  Verification of this bug in no way states that pacemaker works or that you can migrate from rgmanager.
Comment 12 Andrew Beekhof 2010-06-26 04:53:39 EDT
Indeed there is no init script nor binary called pacemaker.
I can imagine that this was probably quite confusing.

If you want to start pacemaker and see it running, then I'd recommend the Clusters from Scratch guide (in PDF or html):

  http://www.clusterlabs.org/doc/en-US/Pacemaker/1.1/pdf/Clusters_from_Scratch/Clusters_from_Scratch.pdf

  http://www.clusterlabs.org/doc/en-US/Pacemaker/1.1/html/Clusters_from_Scratch/index.html

Otherwise, look for me on the internal IRC (beekhof on #cluster) or email and I'll help any way I can.
Comment 14 releng-rhel@redhat.com 2010-11-11 11:21:16 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.