Bug 45690 - Problems with /network/yn/errata/basic.html
Summary: Problems with /network/yn/errata/basic.html
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Other (Show other bugs)
(Show other bugs)
Version: current
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Web Development
QA Contact: Web Development
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 41072
TreeView+ depends on / blocked
 
Reported: 2001-06-24 21:40 UTC by Christopher Blizzard
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 13:49:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Blizzard 2001-06-24 21:40:50 UTC
There are several problems with this page:

1) It sends a multipart/mixed content type that includes an incomplete MIME
message.  The message ends with the closing HTML tag, not a boundry tag as
it should.

2) It sends a bad charset:

Content-Type: multipart/mixed;boundary=xxyyzzzz0011294;
charset=ARRAY(0x94365ec)

3) The refresh URI isn't valid:

This is a multipart reponse in MIME format
--xxyyzzzz0011294
Content-type: text/html; name=Update
Refresh: 5,url=$back_url
Title: Updating

This happens to work in Netscape because it thinks that the URI is bad and
treats it as if the url= parameter wasn't there.

It's interesting to note that there are two problems with Mozilla at the
moment as well:

If you include anything after the content type in the Content-type:
paramter of a multipart/mixed doc it isn't parsed correctly:

Content-type: text/html; name=Update

I have a patch for this that will parse it properly but if you want older
versions to work you might want to remove the ; name=Update from the
content type header.

Also, I've discovered, much to my chagrin, that the Refresh: header doesn't
work at all with multipart/mixed documents.  It doesn't matter if you
include it in the http headers or the headers of the document.  This is a
less easy fix because it's an architecture problem but I'm working on it.

I have to ask.  If the document is being truncated after the first
document, why is it using a multipart document at all?

Comment 1 Jay Turner 2001-09-18 13:49:48 UTC
What's the status of this with the new site?

Comment 2 Jay Turner 2001-09-28 15:51:45 UTC
Closing this out as we are not using any of this on the new site and things are
working pretty well with mozilla and galeon on the new site.  Will reopen if
necessary.


Note You need to log in before you can comment on or make changes to this bug.