Bug 456905 - Add quota support [enhanchement]
Add quota support [enhanchement]
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 11:33 EDT by Balint Cristian
Modified: 2009-01-19 03:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 03:56:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Balint Cristian 2008-07-28 11:33:50 EDT
Description of problem:

postfix currently lack of qouta support
on Maildir creation time, wich is pretty
annoying for a MTA.

 A proposed patch by http://vda.sourceforge.net is aviable.

Proposed and functionality tested pack of rawhide:
http://openrisc.rdsor.ro/postfix.spec
http://openrisc.rdsor.ro/postfix-2.5.1-3.fc9.src.rpm


Excerpt of main.cf for usage:
-------------------------------
virtual_mailbox_limit_inbox = yes
virtual_mailbox_limit_maps = mysql:/etc/postfix/mysql-mboxquotas.cf
virtual_mailbox_limit_override = yes
virtual_overquota_bounce = yes
virtual_maildir_limit_message = "Quota exceeded. Recipient's mailbox is full."
virtual_create_maildirsize = yes


 This patch is floating around since years,personally
tested several years in some enterpriese enviroments
with thousands of accouns, no problem so far using
it on any versions of postfix.
Comment 1 Balint Cristian 2009-01-19 01:33:02 EST

Miroslav,

 Any news ? We are getting F11 soon ..


Some NOTES:
- Nowdays MTA really should be quota 
aware on booth SMTP and IMAP/POP3 side,
in my very opinion.

- Some people would use postfix internal
mail injector which lack of quota support,
but I agree that on most cases folk will
choose dovecot/currier/cyrus's injector
which yes are quota aware, thats why upstream
dont want to use this pach, they forward and
ask you to use other mail injector than 
postfix internal one, since in most cases
postfix is used in conjunction with one
IMAP/POP3 suite.
Comment 2 Miroslav Lichvar 2009-01-19 03:56:05 EST
This really needs to go through upstream. If they don't want to include it, that's bad.

The patch is non-trivial and with postfix I'd like to stay as close to upstream as possible.

Note You need to log in before you can comment on or make changes to this bug.