This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 456908 - adding cxgb3-firmware rpm to rhel
adding cxgb3-firmware rpm to rhel
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Andy Gospodarek
Mike Gahagan
:
: 366861 (view as bug list)
Depends On: 456903
Blocks: 361871 438426 446125 KernelPrio5.3 RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-07-28 11:39 EDT by Andy Gospodarek
Modified: 2009-01-12 20:59 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Deleted Release Notes Contents. Old Contents: cxgb3: driver (along with corresponding firmware) is now included with this release. This driver supports the Chelsio RDMA 10Gb PCI-E Ethernet adapter.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 14:30:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Chelsio's sign-off letter to Red Hat (75.75 KB, application/pdf)
2008-09-22 10:13 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Andy Gospodarek 2008-07-28 11:39:13 EDT
You can find the current versions here:

http://people.redhat.com/agospoda/cxgb3-firmware
Comment 6 Andrius Benokraitis 2008-09-22 10:06:54 EDT
*** Bug 366861 has been marked as a duplicate of this bug. ***
Comment 7 IBM Bug Proxy 2008-09-22 10:13:09 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2007-11-05 09:42 EDT
1. Feature Id 	201220
Feature Name 	Ship the adapter firmware image with driver cxgb3.
Sponsor 	PPC
Category 	Device Drivers and IO
Request Type 	Configuration/Build Change

2. Short Description 	The Chelsio adapter firmware needs to be shipped with the
corresponding driver level on the installation. The firmware will need to be
installed in /lib/firmware directory with other firmware binary images.

The file to be installed is /lib/firmware/t3fw-5.0.0.bin. The binary will be
dropped either by Chelsio or via IBM.

3. Describe the Business Case 	Targeting commercial and HPC cluster segments for
the customers to deploy solutions needing the ethernet standards based
offerings. To ensure the seamless support of the Chelsio RDMA 10Gb PCI-E
Ethernet adapter, the driver level and the corresponding firmware level need to
be shipped on the installation. The support of the cxgb3 driver as well as the
RDMA upper layer functions is in feature request (DevTrack 200959) RHBZ254027.

Performance Assistance Required? 	no

Benefits 	With the firmware repository on the installation, we can support the
long term adapter support through driver/firmware updates. This provides the
mechnism to ensure the compatibility of the Chelsio driver level and the adapter
firmware level.

4. Sponsor Priority 	1
IBM Confidential 	no
Code Contribution ? 	3rd party code
Upstream Acceptance 	No Code Required
Component Release Version Target 	version 5.0
Code Availability Outlook 	Green
Documentation Work 	no
The binary will be dropped either by Chelsio or via IBM.

5. HW to Red Hat: already on site

6. PM Contact: Josh Poulson, jrp@us.ibm.com, 360-857-5053

7. Technical Contact: Wen Xiong, wenxiong@us.ibm.com, 512-838-7922

Too late for 5.2, adding to the 5.3 feature tracker.

Hi Red Hat,

IBM would like to request that this be considered for 5.3.

Thank you,

Emily

IBM is signed up to test and provide feedback

We will need some sign-off from Chelsio that we can legally distribute it before
it is accepted as an rpm that we can ship.



We will check with Chelsio on the sign-off.


Red Hat,
Chelsio has indicated that there is no problem for them to sign off the
firmware distribution to Red Hat. All they need to know is if there is any
forms or any process that they need to follow.

They will provide a sign-off letter and I will attach it here. If there is
anything we need to follow up with. Please let us know if there is any Red Hat
contact for this.

Thanks.


If Chelsio wants us to include their firmware and not ship it with an
open-source compatible license (which I presume is the case since they will
manage firmware create), they will need to make sure to send us the full license
they would like to use so we can include it here

ttp://www.redhat.com/licenses/thirdparty/eula.html

with the rest of the third-party licenses.  We currently ship the firmware for
other NICs (mostly wireless) so those might be good examples.


Hi RedHat,

Based on bug (#441959), Chelsio will update cxgb3 driver to add several new
features and also update driver to check 6.0.0 level adapter firmware.

We think it is better to dup this firmware update feature to Chelsio's feature
(#441959) so that the driver and the firmware can be dropped into RHEL5.3 in
one shot. This is to make sure that the changes will be taken altogether for
better code and testing coordination/tracking.

Thanks,
Wendy


5.3 sounds good to us.  I am still working with our legal team to get the
wording correctly on the agreement (since we need to have the right to
redistribute it as well), but I hope we have it worked out soon.

Just so everyone is aware -- I've talked with legal about this and am
communicating with Chelsio right now to make sure we've got our language squared
away.  Unless Chelsio objects (which I do not suspect they will) I don't think
it will be a problem to get the firmware into RHEL.

This enhancement request was evaluated by the full Red Hat Enterprise Linux team
for inclusion in a Red Hat Enterprise Linux minor release.   As a result of this
evaluation, Red Hat has tentatively approved inclusion of this feature in the
next Red Hat Enterprise Linux Update minor release.   While it is a goal to
include this enhancement in the next minor release of Red Hat Enterprise Linux,
the enhancement is not yet committed for inclusion in the next minor release
pending the next phase of actual code integration and successful Red Hat and
partner testing.
















Check out bug 456908 for more info on the firmware rpm status.

Andy, looks like bug 456908 is a prereq of this bug. Correct? Its status is ON_QA.

*** This bug has been marked as a duplicate of 456908 ***
Comment 8 IBM Bug Proxy 2008-09-22 10:13:17 EDT
Created attachment 317364 [details]
Chelsio&apos;s sign-off letter to Red Hat

Attaching the PDF format file from Chelsio to Red Hat for firmware
distribution.
Comment 9 Andy Gospodarek 2008-09-22 10:30:05 EDT
Just so everyone is aware -- we are updating the cxgb3 driver for 5.3, so we will be including the 6.0.0 firmware instead of the 5.0.0 firmware since the newer version is needed by the newer driver.
Comment 12 IBM Bug Proxy 2008-10-29 23:30:43 EDT
We verified this feature in rhel53_beta1 today. There is one rpm called "
cxgb3-firmware-6.0.0-6.el5.noarch.rpm" in beta1 images. It is great!

Is it possible to install this firmware rpm by default if there is cxgb3 adapter in the system? Our UPT test people complained they have to pull this firmware rpm manually.

Thanks,
Wendy
Comment 13 Neil Horman 2008-10-30 08:32:43 EDT
We're glad you're happy with the result :)

As for default installs, that would really be a question for the anaconda and/or kudzu developers, as the decision to install that package needs to be made at run time.  I would suggest raising the issue with your partner manager here at Red Hat and have them get the appropriate developers involved.
Comment 14 Andy Gospodarek 2008-11-06 10:56:24 EST
I've proposed that we add a line to the kernel spec-file so that the firmware will be installed when the kernel is installed.  This _should_ workaround install/upgrade issues where the firmware isn't available.

Check out bug 469774.
Comment 15 IBM Bug Proxy 2008-11-06 17:20:47 EST
Thanks,Andy!

Based on Andy's comment,  I believed that  the cxgb3-firmware-level will be installed after installation. But I am not sure if the adpater can upgrade/flash firmware during the network installation if doesn't match.

Should need to add /lib/firmware/t3fw-7.0.0.bin into initrd for network installation? Andy,  Can you help us to check with your network installation group people to make sure they build the cxgb3 firmware when do network installation over cxgb3?

Thanks,
Wendy
Comment 16 IBM Bug Proxy 2008-11-12 11:11:05 EST
Since this iis marked verified in devtrack, closing the bug.
Comment 17 Don Domingo 2008-11-20 20:54:46 EST
this bug is now documented in the RHEL5.3 release notes. please consult the following link to view the most recent build of this document:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.3/html-single/Release_Notes/

this document is synced daily. as such, any recent additions are expected to show up within 24 hours or so.
Comment 18 Don Domingo 2008-11-20 20:54:46 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
cxgb3: driver (along with corresponding firmware) is now included with this release. This driver supports the Chelsio RDMA 10Gb PCI-E Ethernet adapter.
Comment 22 Andy Gospodarek 2008-12-22 14:01:13 EST
Deleted Release Notes Contents.

Old Contents:
cxgb3: driver (along with corresponding firmware) is now included with this release. This driver supports the Chelsio RDMA 10Gb PCI-E Ethernet adapter.
Comment 23 Suzanne Yeghiayan 2008-12-23 10:48:27 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Deleted Release Notes Contents.

Old Contents:
cxgb3: driver (along with corresponding firmware) is now included with this
release. This driver supports the Chelsio RDMA 10Gb PCI-E Ethernet adapter.

Note You need to log in before you can comment on or make changes to this bug.