Bug 45691 - Installation - Internal Error
Installation - Internal Error
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-24 18:05 EDT by floyd_o2001
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-01 20:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File dumped from installation process. (10.21 KB, text/plain)
2001-06-24 18:07 EDT, floyd_o2001
no flags Details

  None (edit)
Description floyd_o2001 2001-06-24 18:05:42 EDT
Description of Problem:Installation process failed during formatting of 

How Reproducible:

Steps to Reproduce:

Actual Results:

Expected Results:

Additional Information:
Comment 1 floyd_o2001 2001-06-24 18:07:02 EDT
Created attachment 21686 [details]
File dumped from installation process.
Comment 2 Brent Fox 2001-06-25 10:18:18 EDT
What are the steps required to reproduce this behavior?
Comment 3 floyd_o2001 2001-06-25 22:35:43 EDT
I have two hard drives (hda and hdb) and a cdrom (hdc). I have not been able to 
convince the installation process to talk to the cdrom. It finds it at hdc and 
detects its nature (32x cdrom) but when it tries to read it, errors result and 
it hangs. Windows recognizes it as a generic NEC cdrom. To bypass this problem 
I had copied the cdrom images to hdb and used the 'linux expert' command to 
install from the images. My root partition is on hda. I tried to install and 
the disk driver produced a multitude of errors- disk busy errors, timeouts and 
controller resets. The installation failed part way through the installation of 
packages and the machine rebooted. I then restarted the installation in the 
same way and it failed when it tried to start the formatting of the root 
partition. This resulted in the internal error message with a request to submit 
it to bugzilla. I have subsequently deduced that the disk driver does not take 
kindly to alternate operations on the master and slave drives on the same IDE. 
In this case reads from hdb and writes to hda.  I then moved the cdrom images 
to hda and my installation completed with no problems. Windows has no problem 
with such operations so I assume it is in Linux. I have similar problems with 
my Linux kernel 2.0.25.
Comment 4 Brent Fox 2001-06-26 14:33:23 EDT
Try making a boot disk with the boot.img file in the /images directory on the
cdrom.  Boot with this floppy and then select CDROM installation.  Does this help?
Comment 5 floyd_o2001 2001-06-26 23:48:41 EDT
I have tried that with no luck.  I have completed my installation with the hard 
drive images and the system works well. I am not able to use the cdrom with the 
Linux system either. I assume that the driver is the same in both instances. My 
Linux 2.0.25 kernel works well with the cdrom. I thought I would later rebuild 
the kernel and substitute in the old driver(s) and see if I have any luck. 
There is probably not more that you can do to help me on this, it is either a 
fluke in my system or just my bad luck. I assume it works well for everybody 
Comment 6 Michael Fulbright 2001-06-27 14:00:57 EDT
Brent - would the nodma help here?
Comment 7 Brent Fox 2001-06-27 14:25:14 EDT
floyd_o2001@yahoo.com, can you try booting the installer with 'linux ide=nodma'
and see if that helps?
Comment 8 floyd_o2001 2001-06-28 23:13:43 EDT
I tried the command 'linux ide=nodma' and the result is the same as if I just 
hit <enter> with no command. The systems messages on console 4 are identical.
Comment 9 floyd_o2001 2001-07-01 20:27:08 EDT
I have recompiled the kernel, using K6 architecture and the problem with the 
cdrom has disappeared and some multiple resets of the IDE during boot have also 
disappeared. The system seems to be working normally in that respect now. I can 
mount and read the cdrom. The original dump that opened this bug report is 
probably connected to the IDE problem. I suspect that there is some glitch in 
my cpu that makes it not quite up to an Intel cpu. I suggest that this be 

Note You need to log in before you can comment on or make changes to this bug.