This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 456913 - Buildroot confusion with separately-versioned subpackages
Buildroot confusion with separately-versioned subpackages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 12:03 EDT by Paul Howarth
Modified: 2013-01-09 23:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 08:27:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SRPM exhibiting the problem (2.10 KB, application/octet-stream)
2008-07-28 12:03 EDT, Paul Howarth
no flags Details

  None (edit)
Description Paul Howarth 2008-07-28 12:03:25 EDT
Description of problem:
When building a package where there is a subpackage that has a different version
or release number than the main package, and the last package version/release
mentioned in the spec file is different from the main package version/release,
rpmbuild gets confused by installing packages (%install) into a buildroot named
according to the subpackage version/release but looking for files to package (in
the %files list) and checking for unpackaged files in a buildroot named
according to the main package version/release. As a result, the package build fails.

Version-Release number of selected component (if applicable):
4.5.90-0.git8426.9

How reproducible:
Every time.

Steps to Reproduce:
1. Try to build the attached SRPM in a Fedora 10 root.
  
Actual results:
Build fails like this:
Processing files: testpkg-1.0-1.fc10
Processing files: testpkg-subpkg-2.0-2.fc10
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/builddir/rpmbuild/BUILDROOT/testpkg-2.0-2.fc10.x86_64
error: File not found:
/builddir/rpmbuild/BUILDROOT/testpkg-1.0-1.fc10.x86_64/testfile-main
error: File not found:
/builddir/rpmbuild/BUILDROOT/testpkg-1.0-1.fc10.x86_64/testfile-sub
RPM build errors:
error: Installed (but unpackaged) file(s) found:
   /testfile-main
   /testfile-sub
    File not found:
/builddir/rpmbuild/BUILDROOT/testpkg-1.0-1.fc10.x86_64/testfile-main
    File not found:
/builddir/rpmbuild/BUILDROOT/testpkg-1.0-1.fc10.x86_64/testfile-sub
    Installed (but unpackaged) file(s) found:
   /testfile-main
   /testfile-sub
Child returncode was: 1


Expected results:
Package builds successfully, as it does on Fedora 9 and older releases.
Comment 1 Paul Howarth 2008-07-28 12:03:25 EDT
Created attachment 312790 [details]
SRPM exhibiting the problem
Comment 2 Rex Dieter 2008-07-28 14:05:29 EDT
silly suggestion: don't do that.
Comment 3 Paul Howarth 2008-07-28 15:42:35 EDT
Well if we took the position that separately-versioned subpackages were not
really supported, the current perl package would work by good fortune (the last
subpackage declared in the spec file has the same versioning as the main
package) rather than by design...
Comment 4 Panu Matilainen 2008-07-30 04:27:23 EDT
Right, this is a bug with how the new default buildroot is handled, the spec
defined buildroot isn't *really* ignored and that's where the trouble comes from.
Comment 5 Jeff Johnson 2008-08-03 16:48:13 EDT
Works in rpm-5.0. Thanks for the test case.
Comment 6 Panu Matilainen 2008-08-06 05:31:31 EDT
Fixed upstream, rawhide will get this on the next snapshot update (in a few days).
Comment 7 Jesse Keating 2008-08-06 13:57:56 EDT
This is hitting the samba build too, and I can imagine any number of other packages this will hurt.  We should get this fixed ASAP as we start getting bug reports about alpha packages and need to roll fixes out for them, and as we sprint toward beta.
Comment 8 Panu Matilainen 2008-08-08 08:27:49 EDT
Should be now fixed in rawhide by rpm-4.5.90-0.git8461.1.
Comment 9 Paul Howarth 2008-08-11 05:07:01 EDT
This works for me now - thanks.

Note You need to log in before you can comment on or make changes to this bug.