Bug 456947 - wrapper missing dep on gzip
wrapper missing dep on gzip
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 16:13 EDT by Jesse Keating
Modified: 2013-01-09 22:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 21:30:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-07-28 16:13:17 EDT
I'm having difficulty getting /usr/sbin/wrapper to do the right thing that
anaconda expects, IE writing out a zImage into an output directory.  Looking at
the --help output I see options for -O and -v, -O being output and -v being
verbose.  However using -v I get a usage statement, where the usage statement
says -o is the output, and sure enough, using -O I get a usage statement as well.

Using -o I still don't get an image in my output directory, only something oddly
named in PWD.

/usr/sbin/wrapper -o /out/ppc64.img -i
/srv/pungi/f10-alpha.4/10-Alpha/ppc/os/ppc/ppc64/ramdisk.image.gz -D
/usr/lib/kernel-wrapper/ /srv/pungi/f10-alpha.4/10-Alpha/ppc/os/ppc/ppc64/vmlinuz

seems to just produce 

zImage.4890.o 
zImage.4890.o: ELF 32-bit MSB relocatable, PowerPC or cisco 4500, version 1
(SYSV), with unknown capability 0x41000000 = 0x11676e75, with unknown capability
0x10000 = 0x90402, not stripped


(and last but not least, wrapper fails completely if gzip isn't installed,
kernel-bootwrapper should Require gzip)
Comment 1 Jesse Keating 2008-07-28 17:27:40 EDT
Changing summary as I've narrowed down the main problem, gzip is a requirement
and if not installed, odd things happen.

The documentation being wrong is because '--help' somehow passes into objdump
and the -O and -v is from objdump.
Comment 2 Josh Boyer 2008-07-28 20:54:22 EDT
I'll fix the requires.

Note You need to log in before you can comment on or make changes to this bug.