Bug 456948 - Qt 4.3.5 can't render a dashed ellipse
Qt 4.3.5 can't render a dashed ellipse
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://katecoder.free.fr/divers/debd....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 16:14 EDT by Xavier Guerrin
Modified: 2008-07-28 16:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 16:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Guerrin 2008-07-28 16:14:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; fr) KHTML/3.5.9 (like Gecko)

Description of problem:
The Qt library 4.3.5 seems to be unable to render a dashed ellipse. When this 
library is asked to render an ellipse using a dashed line style, it uses 100% 
CPU and never finishes the rendering. Using a solid line style to draw the 
ellipse is enough to avoid this bug.
This bug was reproduced every time with the qt-4.3.5-2.fc9.i386 package and 
the i386 architecture. However, it never happened with x86_64 or Qt 4.4.

Version-Release number of selected component (if applicable):
qt-4.3.5-2.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1.See attached URL for instructions - it explains how to compile a minimal 
demo program that triggers this bug.
2.
3.

Actual Results:
The program took 100 % CPU and did not display the dashed ellipse pixmap.

Expected Results:
The program should have immediately displayed the dashed ellipse pixmap.

Additional info:
This bug was found while trying to run the program `QElectroTech' - see 
http://blog.famillecollet.com/post/2008/03/09/QElectroTech-01
Comment 1 Kevin Kofler 2008-07-28 16:18:29 EDT
Qt 4.4 is already in updates-testing.

Note You need to log in before you can comment on or make changes to this bug.