Bug 456952 - iota gives result "token undefined"
iota gives result "token undefined"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: aplus-fsf (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 16:52 EDT by Tom Szczesny
Modified: 2008-09-28 16:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 16:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of package differences by environment. (5.82 KB, text/plain)
2008-08-11 11:22 EDT, Tom Szczesny
no flags Details

  None (edit)
Description Tom Szczesny 2008-07-28 16:52:24 EDT
Description of problem:
This problem exists in FC7 and FC8 on the i386 platform.  The problem does not 
exist on the x86_64 platform (at least in FC8).
When in xemacs and using aplus-fsf with the kapl font, the "iota" character is 
generated by Alt-i.  "iota"9 should generate the numbers 0 1 2 3 4 5 6 7 8.  
Instead, I get the error message "token undefined".

Version-Release number of selected component (if applicable):
On an i686 machine, the problem exits 
  in FC8, using   aplus-fsf-4.22.1-3.fc8.i386
  in FC7, using   aplus-fsf-4.22.1-3.fc7.i386
On an x86-64 machine the problem does not exist.  
In FC8, "iota" works fine with both
  aplus-fsf-4.22.1-3.fc8.i386  and with
  aplus-fsf-4.22.1-3.fc8.x86_64

How reproducible:
Use and i686 machine with either FC7 or FC8.  Start up xemacs and aplus-fsf.  
Enter "iota"9 in the "a" buffer.  Hit enter.

Steps to Reproduce:
1.  Use and i686 machine with either FC7 or FC8.
2.  Start up xemacs and aplus-fsf.
3.  Enter "iota"9 in the "a" buffer (where "iota" is Alt-i.  Hit enter.
  
Actual results:   Get the error message "token undefined".

Expected results:   To get the list of 9 numbers:   0 1 2 3 4 5 6 7 8


Additional info:
Comment 1 Tom Szczesny 2008-07-29 14:25:55 EDT
By the way, "iota"9 used to work fine on the i686 platform for both FC7 and FC8.
 I cannot pinpoint exactly when the problem started, but I don't believe that it
corresponded to any updates to aplus-fsf.
Comment 2 Tom Szczesny 2008-07-30 13:39:55 EDT
Status:  Problem exits on i686 platform for F7, F8, and F9, and on x86_64
platform for F9.  aplus-fsf works fine on x86_64 platform for F8.
Cannot find any significant differences between versions of packages between
x86_64/F8 and i686/F8 environments for xemacs nor for aplus-fsf.
Plan to clear a partition and install a fresh environment of x86_64/F8 to see if
system still works in that environment.
Note:  There is an automatic update for an "Updated NetworkManager package" that
repeatedly fails to install on the x86_64/F8 environment, but I don't see why
that  should affect xemacs or aplus-fsf. 
Comment 3 Tom Szczesny 2008-07-31 11:15:09 EDT
Status:  I created a new partition and did a fresh insatll of F8(x86_64) on the
x86_64 platform.  The problem with 'iota'9 (where 'iota' is the character
created by Alt-i) does occur.  I get the error message "token undefined" when I
hit the Enter key.

Next step:  I have two environments on the same machine that are supposed to be
identical.  One in which aplus-fsf works fine, and one in which there is a
serious problem.  These environments are on separate disks.  I intend to clone
the disk with the environment in which aplus-fsf works (to a backup disk) so
that I do not lose this "working" environment as the result of further steps to
identify the problem.

By the way: the NetworkManager package failed to update in the new environment
also.  I will report this in a separate bug report for NetworkManager.  However,
this is further evidence that the NetworkManager problem is unrelated to the
aplus-fsf problem.   
Comment 4 Tom Szczesny 2008-08-01 00:08:02 EDT
Status:  Completed clone of disk (as backup) with F8/x86_64 environment in which
aplus-fsf works.

Next step:  In June 2007 I looked for an environment with a working copy of
aplus-fsf.  The leading candidates were Fedora, Debian and Solaris.  I ruled out
Debian since I could not get the kapl font to work and the 'iota'9 problem
existed in Debian in June 2007.  I reported both problems to Debian.  They fixed
the kapl font problem, but not the 'iota'9 problem.  So, I began to use Fedora,
where aplus-fsf worked fine.  As a next step, I plan to create a new partition
on my x86_64 machine and install a current version of Debian to see if they have
resolved the 'iota'9 problem during the last year, and if so, how.
Comment 5 Tom Szczesny 2008-08-01 00:26:38 EDT
Status:  Re-read my old emails from 2007.  Debian had a host of other problems
regarding aplus-fsf.  The 'iota'9 problem actually existed in F6 and in F7.  It
disappeared in F8 in December of 2007, which was the first time I got aplus-fsf
to work anywhere.  Installing Debian would be of no use in resolving the 'iota'9
problem.

Next step:  Not clear yet.
Comment 6 Tom Szczesny 2008-08-01 08:39:12 EDT
Next step:  I am hoping that there is some package difference between the
F8/x86_64 environment in which aplus-fsf works and the environment in which it
does not.  The aplus-fsf packages and the xemacs packages appear to be the same.
 I will attempt to identify all the dependency packages and check if they are
the  same.
Comment 7 Jochen Schmitt 2008-08-03 13:58:57 EDT
Can you try out this package

http://www.herr-schmitt.de/pub/aplus-fsf/aplus-fsf-4.22.1-3.fc10.1.src.rpm
Comment 8 Tom Szczesny 2008-08-04 00:10:42 EDT
(In reply to comment #7)
> Can you try out this package
> 
> http://www.herr-schmitt.de/pub/aplus-fsf/aplus-fsf-4.22.1-3.fc10.1.src.rpm

I attempted to install the package on the F8/i686 platform.
I downloaded the src.rpm package.
I used the command
    rpm -ivv aplus-fsf-4.22-1-3.fc10.1.src.rpm
which appeared to run to a successful conclusion.
The I used the command
    rpmbuild -ba aplus-fsf.spec
which also appeared to run to a successful conclusion.
This resulted in 6 packages in the directory /usr/src/redhat/RPMS/i386
    aplus-fsf-4.22.1-3.fc8.1.i386.rpm
    aplus-fsf-degubinfo-4.22.1-3.fc8.1.i386.rpm
    aplus-fsf-devel-4.22.1-3.fc8.1.i386.rpm
    fonts-truetype-apl-4.22.1-3.fc8.1.i386.rpm
    fonts-x11-apl-4.22.1-3.fc8.1.i386.rpm
    xemacs-aplus-fsf-4.22.1-3.fc8.1.i386.rpm
However, the listing in Package Manager shows that the package
    aplus-fsf-4.22.1-3.fc8.i386.rpm
is installed on the system. (Note no "1" between the "fc8" and the "i386"
so I don't think the new packages actually got installed.
I must have missed a step or a parameter.  
Any ideas on what I left out?
Comment 9 Tom Szczesny 2008-08-04 11:45:39 EDT
Installed 5 of the 6 packages (all but fonts-truetype-apl-4.22.1-3.fc8.1.i386.rpm) using command     rpm -U     for each package in F8/i686 environment.
Verified that that each package was indeed installed and prior package removed using Package Manager.
Tested result using xemacs and aplus-fsf.
Got same error:    "token undefined"    for  'iota'9

Went back to review 2007 emails to determine nature of problems in Debian.  There were 2 problems: 
   inability to get kapl font to work, and 
   fatal errors when attempting to use in x86_64 environment.  
Both problems might be fixed by now.

Next Fedora step:  Continue to identify package differences between 
   the F8/x86_64 environment that does work with aplus-fsf and 
   the one that does not.
Comment 10 Jochen Schmitt 2008-08-06 16:13:04 EDT
It will be nice, if you can try out this source rpm:

http://www.herr-schmitt.de/pub/aplus-fsf/aplus-fsf-4.22.3-0.11.fc10.src.rpm
Comment 11 Tom Szczesny 2008-08-07 00:57:25 EDT
I installed the package that you sent:
aplus-fsf-4.22.3-0.11.fc10.src.rpm
to my F8/i686 environment.  It did not fix the problem.  Still getting "token undefined" for 'iota'9.

By the way, the A+ website now has a 4.22-4 version posted.  I do not see any explanation of new features or of bug fixes.

Still working on identifying package differences in my F8/x86_64 environment in which aplus-fsf works and my F8/x86_64 environment in which aplus-fsf does not work.
Comment 12 Jochen Schmitt 2008-08-10 14:07:26 EDT
Tahk you for your response.

Because there is a relase 4.22-4 available of the project homepage, I have uploaded the following source rpm:

http://www.herr-schmitt.de/pub/aplus-fsf/aplus-fsf-4.22.4-0.1.fc10.src.rpm

It may be nice, if you cat get a look on it.

Best Regards:

Jochen Schmitt
Comment 13 Tom Szczesny 2008-08-11 09:58:46 EDT
Loaded version 4.22.4 to F8/i686 environment.  Problem with 'iota'9 still exists.

Progress on identifying package differences between the F8/i86_64 environment in which aplus-fsf works and the F8/i86_64 environment in which aplus/fsf does not work:  Since I did not know how to create a file of all installed packages I was manually creating a file for each environment by keying them in.  I had completed the file for the installed packages in the environment that does not work and was up to the P's for the environment that does work.  This morning I just learned that pirut is a graphical front end for yum and that the "yum list installed" command appears to create the file that I need for each environment.  Progress should be much quicker now.  :-)
Comment 14 Tom Szczesny 2008-08-11 11:22:54 EDT
Created attachment 313974 [details]
List of package differences by environment.

I will attempt to incrementally align the packages in the two environments and see if that has any impact.
Comment 15 Tom Szczesny 2008-08-26 20:23:52 EDT
Problem is solved.
It had nothing to do with other installed packages.

It turns out that in setting up the new environments in fresh partitions, I neglected to add the following line to my .bashrc file in each environment:
export LC_ALL=POSIX
to fix the sort problem in coreutils

See the url:
http://www.gnu.org/software/coreutils/faq/coreutils-faq.html#Sort-does-not-sort-in-normal-order_0021

After modifying the .bashrc file and rebooting, the 'iota 9' problem disappears.
Comment 16 Jochen Schmitt 2008-09-10 13:06:51 EDT
I have create aplus-fsf-4.22.4-4 which contains a wrapper who set LC_ALL=POSIX before a+ will be started.
Comment 17 Jochen Schmitt 2008-09-28 16:18:22 EDT
I close this bug, because I assume that the issue is fixed.

Note You need to log in before you can comment on or make changes to this bug.