Bug 456997 - kernel panic when using 2.6.9-78.ELsmp
kernel panic when using 2.6.9-78.ELsmp
Status: CLOSED DUPLICATE of bug 453507
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 01:05 EDT by Victor Orgos
Modified: 2014-09-17 11:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 08:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Victor Orgos 2008-07-29 01:05:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

Description of problem:
The following kernel panic has occurred two nights in a row. Exact message both times, different CPU. This was running on a brand new Dell Poweredge 1950. Two other identical servers, also new, running 2.6.9-67.0.7.ELsmp & 2.6.9-67.0.15.ELsmp have no issues.

The mgeDAE mentioned in the message is the UPS monitoring utility using SNMP to communicate with it. Same tool runs on other PE1950s with no issues.

Jul 29 06:57:51 mail2 kernel: ------------[ cut here ]------------
Jul 29 06:57:51 mail2 kernel: kernel BUG at kernel/exit.c:904!
Jul 29 06:57:51 mail2 kernel: invalid operand: 0000 [#1]
Jul 29 06:57:51 mail2 kernel: SMP 
Jul 29 06:57:51 mail2 kernel: Modules linked in: nfs lockd nfs_acl sunrpc iptable_filter ip_tables sg mptctl mptbase ipmi_devintf ipmi_si ipmi_msghandler dell_rbu parport_pc lp parport autofs4 i2c_dev i2c_core tun dm_mod sr_mod usb_stor
age joydev button battery ac uhci_hcd ehci_hcd i5000_edac edac_mc hw_random shpchp bnx2 ext3 jbd ata_piix libata megaraid_sas sd_mod scsi_mod
Jul 29 06:57:51 mail2 kernel: CPU:    2
Jul 29 06:57:51 mail2 kernel: EIP:    0060:[<c0124cc5>]    Not tainted VLI
Jul 29 06:57:51 mail2 kernel: EFLAGS: 00010046   (2.6.9-78.ELsmp) 
Jul 29 06:57:51 mail2 kernel: EIP is at next_thread+0xc/0x3f
Jul 29 06:57:51 mail2 kernel: eax: 00000000   ebx: d3698c70   ecx: 00000000   edx: ccc6c330
Jul 29 06:57:51 mail2 kernel: esi: 00001fb4   edi: 00001d88   ebp: b7eeb280   esp: c40b7f8c
Jul 29 06:57:51 mail2 kernel: ds: 007b   es: 007b   ss: 0068
Jul 29 06:57:51 mail2 kernel: Process mgeDAE (pid: 31855, threadinfo=c40b7000 task=d3698c70)
Jul 29 06:57:51 mail2 kernel: Stack: c012f536 b3f00a28 e31e23c0 00000000 f624f280 0000000d b7eea680 c016c4d3 
Jul 29 06:57:51 mail2 kernel:        c016c4ed b7eeb280 00000000 00000000 c40b7000 c02e09db b7eeb280 00000000 
Jul 29 06:57:51 mail2 kernel:        006cdff4 00000000 00000000 b7eeb298 0000002b c02e007b 0000007b 0000002b 
Jul 29 06:57:51 mail2 kernel: Call Trace:
Jul 29 06:57:51 mail2 kernel:  [<c012f536>] sys_times+0x56/0x1c5
Jul 29 06:57:51 mail2 kernel:  [<c016c4d3>] sys_fcntl64+0x5f/0x80
Jul 29 06:57:51 mail2 kernel:  [<c016c4ed>] sys_fcntl64+0x79/0x80
Jul 29 06:57:51 mail2 kernel:  [<c02e09db>] syscall_call+0x7/0xb
Jul 29 06:57:51 mail2 kernel:  [<c02e007b>] __lock_text_end+0x880/0x107d
Jul 29 06:57:51 mail2 kernel: Code: 85 c0 89 d3 74 05 e8 53 9c ff ff 53 e8 b9 fb ff ff 0f b6 44 24 04 c1 e0 08 50 e8 ab fb ff ff 89 c2 8b 80 f0 04 00 00 85 c0 75 08 <0f> 0b 88 03 ae 25 2f c0 0f b6 80 04 05 00 00 84 c0 7e 14 a1 80 
Jul 29 06:57:51 mail2 kernel:  <0>Fatal exception: panic in 5 seconds
Jul 29 10:25:31 mail2 syslogd 1.4.1: restart.

Version-Release number of selected component (if applicable):
2.6.9-78.ELsmp

How reproducible:
Always


Steps to Reproduce:
1. Server panics after a few hours.
2.
3.

Actual Results:
Kernel panics

Expected Results:
No kernel panic.

Additional info:
-
Comment 1 Prarit Bhargava 2008-07-29 10:54:18 EDT
Could you please try 78.1 or 78.2 from

http://people.redhat.com/vgoyal/rhel4/RPMS.kernel/

and report back with results.

The sys_times patches were reverted in 78.1.

Thanks,

P.
Comment 3 Victor Orgos 2008-07-29 19:46:48 EDT
Downloaded and installed 78.2 and will update in a day or two.

Vic
Comment 4 Victor Orgos 2008-07-31 19:49:38 EDT
No kernel panic as yet so it must have been the sys_times patch :(

You can close this bug if you wish.

Vic.
Comment 5 Prarit Bhargava 2008-08-06 08:57:06 EDT

*** This bug has been marked as a duplicate of bug 453507 ***

Note You need to log in before you can comment on or make changes to this bug.