Bug 457048 - RHN Satellite should allow FQDN with two parts
RHN Satellite should allow FQDN with two parts
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks: space02
  Show dependency treegraph
 
Reported: 2008-07-29 09:22 EDT by Miroslav Suchý
Modified: 2009-09-17 02:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 02:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-07-29 09:22:28 EDT
+++ This bug was initially created as a clone of Bug #456413 +++

Description of problem:
Satellite 3.6? - 5.x

When trying to install a RHN Proxy on a system that has a FQDN that is built up
as hostname.root, for example "proxy.com", the Satellite refuses to configure
the new Proxy, and returns "proxy.com does not appear to be a valid hostname",
even though it resolves fine. 

According to the Satellite, the following would be an invalid host name:

$ host redhat.com
redhat.com has address 209.132.177.50

The Satellite expects a FQDN to have at least three parts, which makes no sense,
since it is perfectly valid to use hostname.root. The Satellite software
should allow FQDN with at least two parts.

Version-Release number of selected component (if applicable):
3.6? - 5.x

How reproducible:
Always

Steps to Reproduce:
1. Install a RHN Satellite Server
2. Install a RHN Proxy Server
3. Try to "Configure RHN Proxy Server" from the RHN Satellite webGUI, and press
"Continue".
  
Actual results:

Invalid RHN Proxy Hostname: proxy.com does not appear to be a valid hostname.
Invalid RHN Parent Server: satellite.com does not appear to be a valid hostname.

Expected results:
The RHN Satellite Server recognises the valid hostnames and configures the RHN
Proxy Server

Additional info:
This also goes for the Satellite installer, where we have to use --skip-fqdn
with perfectly resolveable hosts.

-- Additional comment from pkrul@redhat.com on 2008-07-23 09:00 EST --
Created an attachment (id=312479)
Patch to fix FQDN subroutines in rhn-base 5.x (source from spacewalk-git-20080702)
Comment 1 Miroslav Suchý 2008-07-29 09:33:28 EDT
Commited to git as:
5956596b2834d77aa588a74d8c215e7b68a57be4
d3de97dbf011b9e20de630e75446f3c9da86f2c9
Comment 2 Jesus M. Rodriguez 2008-09-09 13:59:06 EDT
redhat.com and anything greater than 2 works. A hostname of firebird does not.
Comment 3 Miroslav Suchý 2009-09-17 02:59:42 EDT
Spacewalk is released for long time.

Note You need to log in before you can comment on or make changes to this bug.