Bug 45706 - Should unload modules -- would save many hassles on restore
Should unload modules -- would save many hassles on restore
Status: CLOSED DUPLICATE of bug 44603
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-06-25 00:47 EDT by Bryce Nesbitt
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-26 11:31:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2001-06-25 00:47:03 EDT
I've got a laptop for which $NET_RESTART is not good enough.  I have
to unload the driver also:

[ "$NET_RESTART" = "yes" ] && /etc/rc.d/init.d/network stop &&
        /sbin/rmmod 3c59x && logger "apmscript unloaded 3c59x network

[ "$NET_RESTART" = "yes" ] && modprobe 3c59x &&
        logger "apmscript started 3c59x" && /etc/rc.d/init.d/network start

But frankly, this seems like a good idea anyway.  Why not do a /sbin/rmmod
at the end of the process, and force ALL the unused drivers out of memory?


I fee that the "apmcontinue" script should be capped at the END of shutdown
at the START of restore.  Right now it's always started at the end, which
makes it hard to get the sequencing of things correct.
Comment 1 Bryce Nesbitt 2001-06-25 00:49:01 EDT
That's "called" not "capped"
Comment 2 Bernhard Rosenkraenzer 2001-06-25 07:44:50 EDT
Possibility to reload network modules added in 3.0final-32.
I disagree about starting apmcontinue first after a resume because it's too 
easy to mess up (remember that almost all hardware is still unusable at the 
beginning of resume).
Comment 3 Bryce Nesbitt 2001-06-25 16:04:20 EDT
Then start apmcontine FIRST on shutdown, and LAST on restore.

Look at your own script -- shutdown and restore are mirrors of each other.
The same need is present in apmcontinue.

Comment 4 Bernhard Rosenkraenzer 2001-06-26 11:31:33 EDT
Same problem. If the user already shuts down a piece of hardware and the apmd 
script tries to do it again, the system is messed up.

What do you think about creating an additional "apmstart" script that is run 
at the beginning of suspends and resumes?
Comment 5 Bernhard Rosenkraenzer 2001-06-26 12:29:12 EDT
(This part has already been suggested and done in 3.0final-33)

*** This bug has been marked as a duplicate of 44603 ***

Note You need to log in before you can comment on or make changes to this bug.