Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 457084 - wireless mac80211 broken in 2.6.26 gits
Summary: wireless mac80211 broken in 2.6.26 gits
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-29 15:21 UTC by Need Real Name
Modified: 2008-08-16 19:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-16 19:37:15 UTC
Type: ---


Attachments (Terms of Use)

Description Need Real Name 2008-07-29 15:21:47 UTC
Description of problem:
The wireless support in the 2.6.26 git releases and the 2.6.27 rc releases is
broken due to a latent bug that has been exposed.

Version-Release number of selected component (if applicable):
kernel-2.6.27-0.186.rc0.git15.fc10

How reproducible:
Always. Drivers which use mac80211 like ath5k and ath9k will have
timeouts when associating with the AP.

Steps to Reproduce:
1. Install kernel-2.6.27-0.186.rc0.git15.fc10 and use the ath5k or ath9k
wireless drivers.
  
Actual results:
Expected normal wireless connections.

Expected results:
Connections only survive a couple minutes before timeout errors with AP
associations occur.

Additional info:
The current proposed fix for this is at...

http://marc.info/?l=linux-wireless&m=121732394028001&w=2


Note You need to log in before you can comment on or make changes to this bug.