Bug 457104 - improve upgrades to RHEL6
improve upgrades to RHEL6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: David Teigland
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 12:46 EDT by David Teigland
Modified: 2009-04-16 19:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:53:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
groupd patch (4.74 KB, text/plain)
2008-08-21 18:09 EDT, David Teigland
no flags Details

  None (edit)
Description David Teigland 2008-07-29 12:46:55 EDT
Description of problem:

Rolling upgrades from RHEL5 to RHEL6 will work better if we add code
to RHEL5 groupd that sends out a message advertising its version.
Without this, RHEL6 groupd assumes an old version after not receiving
a version message after a timeout period.  The timeout+assumption works
(and needs to for rolling upgrades of 5.1 or 5.2 to RHEL6), but is obviously
slower and less reliable than actually getting a message.  The sooner we
include this in RHEL5, the more likely that RHEL5->6 upgrades can take advantage
of this improvement.  These version messages will not affect the behavior of a
RHEL5-only cluster.

Another future problem we can mitage now, is the case where RHEL6 nodes form
a new cluster, and select the new incompatible groupd mode because no RHEL5
nodes are found (this "auto-detection" is the behavior we want).  Then, an
old RHEL5 node joins the cluster (people shouldn't do this, but it may happen).
 It would be nice to prevent the old RHEL5 groupd from doing
anything, because it won't be in sync with the RHEL6 nodes running in the
new mode.  The simplest way to do this is for the old groupd to look at the
version messages from the new RHEL6 nodes, and exit when it sees they are
incompatible.  Again, this will only affect the groupd behavior once there
are mixed RHEL5/RHEL6 nodes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2008-07-29 13:00:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 David Teigland 2008-08-21 18:09:31 EDT
Created attachment 314758 [details]
groupd patch

Patch is attached.  Have now tested this on RHEL5 without problems.
There's not much to test, really, because the new code never does
anything; it just sends a new message that's ignored.  Most of the
new code is the standard setup for a new message type.

The RHEL6 version of groupd will actually use these new messages
being sent to "see" the RHEL5 nodes.
Comment 3 David Teigland 2008-08-26 12:44:53 EDT
pushed to RHEL5 and STABLE2 branches
Comment 6 errata-xmlrpc 2009-01-20 16:53:15 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0189.html

Note You need to log in before you can comment on or make changes to this bug.