Bug 457109 - (TAP-Harness-JUnit) Review-Request: perl-TAP-Harness-JUnit - Generate JUnit compatible output from TAP results
Review-Request: perl-TAP-Harness-JUnit - Generate JUnit compatible output fro...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
http://netbsd.sk/~lkundrak/SPECS/perl...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 13:12 EDT by Lubomir Rintel
Modified: 2014-03-06 08:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 18:14:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mmahut: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2008-07-29 13:12:04 EDT
SPEC: http://netbsd.sk/~lkundrak/SPECS/perl-TAP-Harness-JUnit.spec
SRPM: http://netbsd.sk/~lkundrak/SRPMS/perl-TAP-Harness-JUnit-0.01-1.el5.src.rpm

Description:

The only difference between this module and TAP::Harness is that this adds
mandatory 'xmlfile' argument, that causes the output to be formatted into
XML in format similar to one that is produced by JUnit testing framework.
Comment 1 Jason Tibbitts 2008-08-10 18:57:09 EDT
I note that upstream has updated this package twice since this ticket was opened, but I guess you know that since you're the upstream.

Should we wait for an updated package?
Comment 2 Lubomir Rintel 2008-08-11 06:25:04 EDT
Jason: No need to. The changes did not affect the way this is packaged, so the spec file remains basically the same.
Comment 3 Lubomir Rintel 2008-09-09 17:25:53 EDT
ping?
Comment 4 Marek Mahut 2008-11-01 09:43:02 EDT
Package looks sane.

+ source files match upstream:
        bdf902ea7a92272def706871a6c1bd5e  TAP-Harness-JUnit-0.01.tar.gz
+ package meets naming and versioning guidelines.
+ dist tag is present
+ build root is correct
+ license is ok
+ latest version is being packaged
+ package builds in mock (f8, devel)
+ rpmlint is silent  

APPROVED
Comment 5 Lubomir Rintel 2008-11-01 16:23:32 EDT
New Package CVS Request
=======================
Package Name: perl-TAP-Harness-JUnit
Short Description: Generate JUnit compatible output from TAP results
Owners: lkundrak
Branches: EL-5 F-9 F-10
Comment 6 Dennis Gilmore 2008-11-03 13:50:15 EST
CVS Done
Comment 7 Lubomir Rintel 2008-11-03 18:14:55 EST
Thanks Marek.
Thanks Dennis.
Imported and built.
Comment 8 Lubomir Rintel 2014-03-04 05:20:03 EST
Package Change Request
======================
Package Name: perl-TAP-Harness-JUnit
New Branches: epel7
Owners: lkundrak eseyman

A message from eseyman, the current Fedora maintainer of the package: "I don't use EPEL so I'm probably not the best choice for a maintainer. Feel free to ask for a branch for any of my modules. If you do, please consider adding me as co-maintainer."
Comment 9 Gwyn Ciesla 2014-03-06 08:18:41 EST
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.