Bug 457126 - anaconda traceback trying to install from split media (CDs)
anaconda traceback trying to install from split media (CDs)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-07-29 15:27 EDT by Will Woods
Modified: 2014-01-21 01:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 15:33:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (74.86 KB, text/plain)
2008-07-29 16:03 EDT, Will Woods
no flags Details
screenshot of anaconda reporting the transaction error (29.94 KB, image/png)
2008-07-29 16:05 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2008-07-29 15:27:02 EDT
With anaconda 11.4.1.20 (which uses rpm 4.5.90-0.git8426.9), we get a traceback
when anaconda tries to switch CDs. The error message claims that rpm and kernel
are already in the transaction. These two packages are notable because they have
%posttrans scripts.

Logs forthcoming.
Comment 1 Will Woods 2008-07-29 16:03:14 EDT
Created attachment 312927 [details]
anaconda.log

anaconda.log from machine attempting a hdiso install of CD images.
most relevant lines are at the end:
19:57:23 ERROR	 : package already installed: package
rpm-4.5.90-0.git8426.9.i386 is already installed
19:57:23 ERROR	 : package already installed: package
kernel-2.6.27-0.166.rc0.git8.fc10.i686 is already installed
Comment 2 Will Woods 2008-07-29 16:05:38 EDT
Created attachment 312929 [details]
screenshot of anaconda reporting the transaction error
Comment 3 Jesse Keating 2008-07-31 22:17:41 EDT
I do believe this is fixed with a test build of rpm.  This change to rpm allows
rpm to get the %posttrans content from the rpmdb rather than the .rpm file
itself.  This removes the need to go back and get the .rpm file at the end of
the transaction.
Comment 4 Will Woods 2008-08-01 14:04:13 EDT
Doesn't seem to be fixed, at least not for the way anaconda performs the
transaction(s).
Comment 5 Chris Lumens 2008-08-04 15:33:53 EDT
This will be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.