Bug 457147 - missing "lock screen" menu item
missing "lock screen" menu item
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 17:09 EDT by John Ellson
Modified: 2015-01-14 18:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 19:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2008-07-29 17:09:18 EDT
Description of problem:
Some recent change in rawhide lost the "lock screen" feature.  I can't find
a menu item of an applet to easily lock the screen.

I may not be reporting against the right package?  Please redirect as needed.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.20.0-12.fc8.x86_64

How reproducible:
100%

Steps to Reproduce:
1.login to gnome desktop session
2.look for "lock screen"
3.
  
Actual results:
gone

Expected results:
Ability to easily lock the screen when walking away from the computer for a while.

Additional info:
Comment 1 Matthias Clasen 2008-07-31 21:17:55 EDT
Very odd. Why do you have an f8 build of gnome-screensaver installed, when this
is a supposedly a rawhide bug report ?
Comment 2 John Ellson 2008-07-31 21:37:28 EDT
Sorry, must have got the rpm version from the other system i was comparing with.

Version installed is: gnome-screensaver-2.23.3-0.2008.05.29.3.fc10.x86_64
Comment 3 Matthias Clasen 2008-07-31 23:52:57 EDT
Hmm, I have that version installed, and I do have the lock screen menuitem and
the lock screeen applet.
Comment 4 John Ellson 2008-08-01 07:28:52 EDT
I tried a different user on the same system, and that had a Lock menu item and
applet, so I seem to have damaged some $HOME/.*  file, but what?

I tried: rpm -ivh --replacepkgs gnome-session gnome-panel gnome-screensaver GConf
but that didn't fix it.

Is there a way to reinitialize a default gnome desktop?
Comment 5 Matthias Clasen 2008-08-01 14:03:22 EDT
is gnome-screensaver actually running in the problematic session ?
Comment 6 John Ellson 2008-08-01 18:35:07 EDT
Yes, its running, and it works.  It can lock the screen when it times-out.

I just can't lock the screen manually from a menu or applet.
Comment 7 John Ellson 2008-08-31 18:07:59 EDT
This one still has me totally stumped.


With "ellson"  not logged in, I used root to:
    mv /home/ellson /home/ellson.SAVE
    mkdir /home/ellson
    chown ellson:ellson ellson

Then I rm'd everything in /tmp and /var/tmp, including all the .files,
then I rebooted.

On the freshly booted system I logged in as ellson.   My desktop
was cam up as the default, *except* that I still have no lock screen menu item!!!

Logging in as other users gets a lock screen menu item.


So where-o-where is this per-user state being kept ?
Comment 8 John Ellson 2008-08-31 18:09:15 EDT
s/was cam/came/
Comment 9 Mark McLoughlin 2008-09-11 11:55:49 EDT
I suspect your path is screwed up. The code is:

        if (panel_is_program_in_path ("gnome-screensaver-command")
            && panel_is_program_in_path ("gnome-screensaver-preferences"))
                use_gscreensaver = TRUE;

Check that both of these commands are in the $PATH as seen by gnome-panel
Comment 10 John Ellson 2008-09-11 12:12:18 EDT
Both are in my $PATH and in the $PATH of other userids.

    ellson@ontap:Desktop> which gnome-screensaver-command
    /usr/bin/gnome-screensaver-command
    ellson@ontap:Desktop> which gnome-screensaver-preferences
    /usr/bin/gnome-screensaver-preferences
    ellson@ontap:Desktop> whoami
    ellson

Note that this problem occurs even for a brand-new userid IFF it is called "ellson"
Comment 11 John Ellson 2008-09-11 19:52:45 EDT
The "problem" was likely caused by me playing with "pessulus".

Corrected by running:  System -> Preferences -> Lockdown Editor
and re-enabling lock screen.

My bad.

Note You need to log in before you can comment on or make changes to this bug.