Bug 457165 - Kernel 2.6.25.10-86 and following are not bootable
Kernel 2.6.25.10-86 and following are not bootable
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
powerpc Linux
urgent Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 20:14 EDT by Stefan Posdzich
Modified: 2008-09-10 03:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-31 07:43:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Posdzich 2008-07-29 20:14:51 EDT
Description:

kernel-2.6.25.10-86.fc9 and the following are not bootable on my PowerPC
(Playstation 3).
Last working kernel is kernel-2.6.25.10-85.fc9.
I have tested rawhide, but it is also not bootable.

The last message from the kernels is:

ps3_system_bus_match:352:dev=2(sb_08),drv=1(ps3-ehci-driver):miss

This problem is probably caused by commit de85422b
Comment 1 ^mp3axe^ 2008-08-01 15:07:10 EDT
I can confirm kernel-2.6.25.11-97.fc9.ppc64 is still not bootable.  I see a hang
at the Red Hat Nash message.
Comment 2 Andrea 2008-08-03 14:25:21 EDT
I have a similar issue.
I've updated today 03/08/07 Fedora 9 (previously updated on 11/07/08).

For me the last message on screen is just a few lines after yours and it is

ps3-ehci-driver sb_05 USB 0.0 started, EHCI 1.00, driver 10 Dec 2004
hub 1-0:1.0 USB hub found
hub 1-0:1.0 2 ports detected

Is it possible to boot with the previous kernel?
I don't know how to do it with kboot.
How to go back to Sony?

Cheers
Comment 3 Stefan Posdzich 2008-08-04 05:04:34 EDT
>> Is it possible to boot with the previous kernel? <<

Press "tab" at kboot and you, hopefully, can choose your old Kernel.

>> How to go back to Sony? <<

You mean the XMB? Kboot -> ps3-boot-game-os
Comment 4 ^mp3axe^ 2008-08-04 19:04:20 EDT
 
> Is it possible to boot with the previous kernel?
> I don't know how to do it with kboot.


Usually, press tab at the kboot prompt, and you should be able to select the previous kernel.

If this doesn't work, do the following:
1) insert the Fedora 9 PPC DVD and type 'linux rescue' at the kboot prompt
2) once this starts, select your languages, keboard, etc
3) answer no to networking
4) scan for linux distributions, which it should find, and if it is successful, it should tell you to type in 'chroot /mnt/sysimage'
5) do so at the terminal prompt that follows
6) once this successful, you should see your linux installation
7) now, edit /etc/yaboot.conf and completely comment out or remove the lines pertaining the bad kernel
Comment 5 Andrea 2008-08-05 16:35:29 EDT
Thanks, the TAB shows labels of the existing kernels and the previous one works.

It is a bit off topic, but I seem not to understand the difference between kboot and yaboot.

Do you know how it works?
Comment 6 ^mp3axe^ 2008-08-05 16:51:49 EDT
(In reply to comment #5)
> Thanks, the TAB shows labels of the existing kernels and the previous one
> works.
> 
> It is a bit off topic, but I seem not to understand the difference between
> kboot and yaboot.
> 
> Do you know how it works?

As an over simplification:

- yaboot is a bootloader for ppc based linux distributions
- kboot is a transparent bootloader that acts as a middleman between ps3 and the linux distribution, allowing Ps3 to boot linux
Comment 7 Andrea 2008-08-06 14:36:25 EDT
(In reply to comment #6)
> (In reply to comment #5)
> 
> As an over simplification:
> 
> - yaboot is a bootloader for ppc based linux distributions
> - kboot is a transparent bootloader that acts as a middleman between ps3 and
> the linux distribution, allowing Ps3 to boot linux

Thanks for the quick overview,

where can I ask more questions or find documentation?
I think this bug report is not really the right place...

Andrea
Comment 8 Kazunori Asayama 2008-08-11 03:54:23 EDT
(In reply to comment #7)
> where can I ask more questions or find documentation?
> I think this bug report is not really the right place...

Use cbe-oss-dev@ozlabs.org for general discussion about Linux on PS3.

  https://ozlabs.org/mailman/listinfo/cbe-oss-dev

You can find resources related to Linux on PS3 at:

  http://www.kernel.org/pub/linux/kernel/people/geoff/cell/
Comment 10 Chuck Ebbert 2008-08-19 21:54:11 EDT
(In reply to comment #9)
> Geoff provides a workaround patch:
>  
> http://git.kernel.org/?p=linux/kernel/git/geoff/ps3-linux-patches.git;a=commit;h=38afc862fe863c430a29207b914a7ee64250a3a3

That patch reverts code that was added in 2.6.27-rc.
Comment 11 Kazunori Asayama 2008-08-19 23:06:17 EDT
(In reply to comment #10)
> That patch reverts code that was added in 2.6.27-rc.

Ah, you're right. I mistook this problem for another one...
Comment 12 Kazunori Asayama 2008-08-24 23:44:57 EDT
(In reply to comment #0)
> This problem is probably caused by commit de85422b

http://git.kernel.org/?p=linux/kernel/git/geoff/ps3-linux-patches.git;a=commit;h=0a26a81e23bc8c3be5b39f28698201b676b57321

This patch should fix the problem. I tried it with vanilla 2.6.25.13 and 2.6.26.2, then it worked.
Comment 13 Stefan Posdzich 2008-08-31 07:43:11 EDT
Kernel is booting again:

kernel-2.6.26.3-27.fc9

* Fri Aug 29 2008 Chuck Ebbert <cebbert@redhat.com> 2.6.26.3-19
- USB: fix hcd interrupt disabling (#457165)
Comment 14 Fedora Update System 2008-08-31 11:02:11 EDT
kernel-2.6.26.3-27.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-27.fc9
Comment 15 Fedora Update System 2008-09-03 12:49:21 EDT
kernel-2.6.26.3-29.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-29.fc9
Comment 16 Fedora Update System 2008-09-05 08:19:22 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2008-09-10 03:06:44 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.