Bug 457178 - Remove deprecated TAM view link
Remove deprecated TAM view link
Status: CLOSED CURRENTRELEASE
Product: Issue-Tracker
Classification: Retired
Component: User Interface (Show other bugs)
MR15
All Linux
medium Severity medium
: ---
: ---
Assigned To: Issue-Tracker Bug Watch List
David Spalding
:
Depends On:
Blocks: 521861 523261
  Show dependency treegraph
 
Reported: 2008-07-29 21:48 EDT by Gary Case
Modified: 2015-01-19 19:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-19 16:24:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Case 2008-07-29 21:48:05 EDT
The "Manager" privilege once allowed users to create TAM summaries. Those have
been phased out, so there is no need to keep the privilege. Please remove it.
Comment 1 Mike Amburn 2008-10-30 14:44:43 EDT
I believe Manager is actually used to provide additional features. Lisa?
Comment 2 Lisa Lu 2008-10-30 14:52:14 EDT
Gary,

"manager" priv. is used for the following access:
  - [TAM Summary], located on the left nav. bar below "Groups"
  - Internal Status hot link located on the left nav. bar
  - manager report, located on the left nav. bar below "Reports"

Lisa
Comment 3 Lisa Lu 2008-10-30 14:54:07 EDT
(In reply to comment #2)
> Gary,
> 
> "manager" priv. is used for the following access:
>   - [TAM Summary], located on the left nav. bar below "Groups"
>   - Internal Status hot link located on the left nav. bar
>   - manager report, located on the left nav. bar below "Reports"
> 
> Lisa

Please verify if you need/don't need the other related hotlinks any more.

Lisa
Comment 4 Mike Amburn 2009-07-07 10:49:13 EDT
Gary, can you confirm Lisa's comment?
Comment 5 Gary Case 2009-07-07 13:06:51 EDT
Mike and Lisa,

I don't actually see the Manager Report and the Internal Status links in the left navigation bar. Are those only for admins?

-Gary
Comment 6 Lisa Lu 2009-09-08 15:23:19 EDT
(In reply to comment #5)
> Mike and Lisa,
> 
> I don't actually see the Manager Report and the Internal Status links in the
> left navigation bar. Are those only for admins?

Nope, they are for users with 'manager' permission. Since you are not very familiar with 'manager' permission, Here are the full list of places that reference 'manager' permission
   - Create System/global Announcement.
   - Generate Manager report
   - Receive Management Attention notification
   - Access Internal Statuses page
   - [TAM Summary]

If TAMs no longer use [TAM Summary], I recommend we remove that link from the page without deprecating 'Manager' privilege.
 
Lisa
Comment 7 Gary Case 2009-09-08 15:41:17 EDT
Lisa,

That sounds good to me. We no longer use TAM Summaries, so the link can go away.

-Gary
Comment 8 Lisa Lu 2009-09-08 16:13:29 EDT
(In reply to comment #7)
> Lisa,
> 
> That sounds good to me. We no longer use TAM Summaries, so the link can go
> away.
> 
> -Gary  

Thanks Gary!

Lisa
Comment 9 David Spalding 2009-09-18 17:27:42 EDT
Verified TAM Summary link removed.

Note You need to log in before you can comment on or make changes to this bug.