Bug 457209 - firefox-3.0.1-1.fc9.src.rpm does not yield installable firefox-3.0.1-x.fc9.rpm
firefox-3.0.1-1.fc9.src.rpm does not yield installable firefox-3.0.1-x.fc9.rpm
Status: CLOSED DUPLICATE of bug 437608
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
http://download.fedora.redhat.com/pub...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 05:32 EDT by Edwin ten Brink
Modified: 2008-11-12 05:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 05:00:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of rpmbuild --rebuild firefox*.src.rpm 2>&1 (1.92 MB, text/plain)
2008-07-30 18:45 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Edwin ten Brink 2008-07-30 05:32:21 EDT
Description of problem:
Rebuilding firefox-3.0.1 package does not yield an installable rpm. Installation
of the freshly created rpm fails with:

# rpm -U firefox-3.0.1-3.fc9.i386.rpm 
error: unpacking of archive failed on file
/usr/lib/firefox-3.0.1/firefox;48902426: cpio: MD5 sum mismatch

No system- or user specific rpmrc was used, source package was unmodified,
except for the release number in the /usr/src/redhat/SPECS/firefox.spec file.


Version-Release number of selected component (if applicable):
# gcc --version
gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)
# rpmbuild --version
RPM version 4.4.2.3
# cpio --version
cpio (GNU cpio) 2.9


How reproducible:
Always.


Steps to Reproduce:
With the downloaded source rpm from
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/SRPMS/firefox-3.0.1-1.fc9.src.rpm

1. # rpm -i firefox-3.0.1-1.fc9.src.rpm
2. # cd /usr/src/redhat/SPECS
3. // Edit of the release number x in the firefox.spec file.
4. # rpmbuild -ba firefox.spec 
5. # cd ../RPMS/i386
6. # rpm -U firefox-3.0.1-x.fc9.i386.rpm   // x being the release number

  
Actual results:
"error: unpacking of archive failed on file
/usr/lib/firefox-3.0.1/firefox;48902426: cpio: MD5 sum mismatch"

Package was not installed.

The number  in "firefox;48902426: cpio: MD5 sum mismatch" varies each time a
rebuild is attempted, even with the same settings. 


Expected results:
No output but clean install.


Additional info:
none
Comment 1 Matěj Cepl 2008-07-30 18:24:40 EDT
Weird, I actually can reproduce this. Although the build goes without problems
and the resulting package looks good:

[matej@viklef ~]$ rpm --checksig --nosignature
redhat/RPMS/i386/firefox-3.0.1-1.fc9.i386.rpm 
redhat/RPMS/i386/firefox-3.0.1-1.fc9.i386.rpm: sha1 md5 OK
[matej@viklef ~]$ 

I get the same error message when trying to upgrade
[root@viklef ~]# LANG=C rpm -Uvh --force
/home/matej/redhat/RPMS/i386/firefox*3.0.1-1*
Preparing...                ########################################### [100%]
   1:firefox                ########################################### [ 50%]
error: unpacking of archive failed on file
/usr/lib/firefox-3.0.1/firefox;4890e9b1: cpio: MD5 sum mismatch
   2:firefox-debuginfo      ########################################### [100%]
[root@viklef ~]# 

Comment 2 Matěj Cepl 2008-07-30 18:45:22 EDT
Created attachment 313048 [details]
output of rpmbuild --rebuild firefox*.src.rpm 2>&1

There is interesting stuff here:

[matej@viklef redhat]$ grep ^Warning rpmbuild-log.txt |wc -l
264
[matej@viklef redhat]$ 
[matej@viklef redhat]$ grep ^Warning -C 3 rpmbuild-log.txt |head -n 5
Creating package directory...
rm -f -rf ../../dist/xpt
/usr/bin/perl -I../../xpinstall/packager -e 'use Packager; Packager::Copy(
"../../dist", "../../dist/firefox", "packages-static", "unix", 1, 0, 1);'
Warning: package error or possible missing or unnecessary file:
bin/defaults/existing-profile-defaults.js (packages-static, 18).
Warning: package error or possible missing or unnecessary file: bin/libmozjs.so
(packages-static, 32).
[matej@viklef redhat]$ 

(other 250+ lines are roughly the same, except the filename is different).
Comment 3 Jan Horak 2008-11-12 05:00:58 EST

*** This bug has been marked as a duplicate of bug 437608 ***

Note You need to log in before you can comment on or make changes to this bug.