This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 457245 - kernel oops + lockup in utrace at gdm startup
kernel oops + lockup in utrace at gdm startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-07-30 10:25 EDT by Will Woods
Modified: 2013-01-09 23:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-05 13:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-07-30 10:25:38 EDT
Current rawhide - kernel 2.6.27-0.186.rc0.git15.fc10

At gdm startup, something goes wrong on my system. gdb gets started - presumably
to trace the problem - and then the kernel emits an oops in
get_utrace_lock_attached. 

The system is then soft-locked. 60s later I get a BUG: soft lockup from gdm-binary. 

Unfortunately, since the system is locked, it's hard to get full oops logs.
Here's a summary of the soft lockup trace:

__delay
_raw_spin_lock
_spin_lock
finish_callback
? ptrace_report_signal
utrace_get_signal
? check_object
? ptrace_report_signal
get_signal_to_deliver
? trace_hardirqs_on
do_notify_resume
? remove_wait_queue
? trace_hardirqs_on_caller
? trace_hardirqs_on
? do_wait
? default_wake_function
? path_put
work_notifysig

I'll try to get info on the original Oops, but it's tricky, since I only get 60
seconds to copy info down before the soft lockup BUG is triggered.
Comment 1 Will Woods 2008-07-30 10:29:58 EDT
Here's what I could copy down in those 60s:

utrace_control
ptrace_detach_utrace
ptrace_attach
sys_ptrace
syscall_call
__mutex_unlock_slowpath

EIP: [<c045fa72>] get_utrace_lock_attached+0x5e/0x91 SS:ESP 0068:f2b89f44
Comment 2 Will Woods 2008-07-30 10:46:57 EDT
kernel 2.6.27-0.166.rc0.git8.fc10 (the kernel currently tagged for F10Alpha)
does not have this bug. 

The gdm crash that triggers this seems to have been brought on by an SELinux
denial. Booting with 'enforcing=0' works fine.
Comment 3 Jesse Keating 2008-10-03 19:36:25 EDT
So can this be closed, or is it still happening?
Comment 4 Will Woods 2008-10-03 22:51:21 EDT
Well, the kernel bug that was triggering this is fixed, so it's hard to tell if the gdb + utrace lockup is still around.

Still, I tried killing Xorg off while gdm was up (killall -SEGV Xorg) and nothing bad happens, and there have been plenty of other X crashes that didn't cause anything like this. So unless someone came up with a better way to reproduce the old trigger, I'd consider it fixed.

Note You need to log in before you can comment on or make changes to this bug.