Bug 457251 - RFE: yum should check rpmlib() requirements, eg. LZMA
RFE: yum should check rpmlib() requirements, eg. LZMA
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On: 457095
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 11:06 EDT by Florian Festi
Modified: 2014-01-21 18:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 12:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Festi 2008-07-30 11:06:55 EDT
+++ This bug was initially created as a clone of Bug #457095 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615
Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
On attempting to install viking-0.9.4-2.5.i586.rpm got message 
ERROR with rpm_check_debug vs depsolve : rpmlib(PayloadIsLzma) is needed by
viking...please report this error in bugzilla

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Double-click package file
2.Enter root password
3.wait

Actual Results:


Expected Results:


Additional info:

-- Additional comment from ffesti@redhat.com on 2008-07-29 15:27 EST --
Looks like you are trying to install a package that was created by a more recent
version of rpm that does support Lzma compression while your own rpm version
doesn't. Can you please add a link to the package you are trying to install and
state what distribution you are using.

-- Additional comment from doug@tulloch.info on 2008-07-29 15:46 EST --
http://download.uni-hd.de/ftp/pub/linux/opensuse/repositories/Application:/Geo/openSUSE_11.0/i586/viking-0.9.4-2.5.i586.rpm

I'm using Fedora 9
Comment 1 Florian Festi 2008-07-30 11:11:31 EDT
Cloning as yum bug:

Yum should have detected this problem before rpm_check_debug. Perhaps yum should
even create special error messages explaining that problems with these
requirements are the result of incompatible rpm packages.

It is very likely that the rpmlib Python bindings do not yet provide enough
information to handle this.
Comment 2 James Antill 2008-07-30 11:43:02 EDT
 So we have a couple of problems here (on the yum side):

1. We remove everything that starts "rpmlib(" from the repo. metadata, to save a
huge amount of space (obviously at this point we can't know what the client
system's rpm handles).

2. We ignore anything starting "rpmlib(" when we check the requires/provides of
any packages.

...in theory we could fix #2 (assuming we have APIs to list what the current rpm
provides), so a local "yum install blah.rpm" would do the right thing. But
that's a pretty weird edge case.
 To fix #1 we need some way to say "this repo. has these rpmlib() requirements"
(just putting them all back in is almost certainly a big lose). I know Seth was
thinking of putting that data in the repomd.xml ... but that hasn't happened yet.
 We're open to options (and patches :), but this isn't high on the TODO list.
Comment 3 Jeremy Katz 2008-07-30 11:56:50 EDT
The reason we ignore them is there's nothing we can do about them.  If you're
running yum and have packages with a new rpmlib() dep, then the only thing you
can do is update rpm (and hope it doesn't have the new rpmlib() dep) and then
restart the process entirely.  You can't just update rpm at the same time and
have things work.
Comment 4 seth vidal 2009-01-21 13:07:32 EST
Any new thoughts on what we should do here?
Comment 5 seth vidal 2009-07-10 12:25:16 EDT
closing this as cantfix.

we're just sol.

Note You need to log in before you can comment on or make changes to this bug.