This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 457341 - On Thinkpad T61, both built-in and USB keyboards not functional
On Thinkpad T61, both built-in and USB keyboards not functional
Status: CLOSED DUPLICATE of bug 456680
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 20:56 EDT by Michel Alexandre Salim
Modified: 2008-07-31 02:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 02:49:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log generated when I started X using startx as a normal user (65.93 KB, text/plain)
2008-07-30 20:56 EDT, Michel Alexandre Salim
no flags Details

  None (edit)
Description Michel Alexandre Salim 2008-07-30 20:56:20 EDT
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-server-1.4.99.906-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. Boot from Rawhide's boot.img
2. Elect to do a graphical install
3. Try to use the keyboard
4. Alternatively, do a text/VNC install
5. Boot into runlevel 3 (GDM causes kernel panic otherwise)
6. As a normal user, startx  

Actual results:
Both internal and USB keyboards not functional. Both work in the virtual console.

Expected results:
Keyboard should be auto-configured

Additional info:
/var/log/Xorg.0.log attached
Comment 1 Michel Alexandre Salim 2008-07-30 20:56:20 EDT
Created attachment 313061 [details]
Log generated when I started X using startx as a normal user
Comment 2 Michel Alexandre Salim 2008-07-30 21:09:02 EDT
Problem appears to be that, when starting X without an xorg.conf, for some
reason it does not configure a keyboard. Using an auto-generated xorg.conf from
X -configure solves the problem for now (but perhaps the installer should be
fixed to either ship with a minimal xorg.conf, or to generate one before
starting x?)
Comment 3 Peter Hutterer 2008-07-31 02:49:11 EDT

*** This bug has been marked as a duplicate of 456680 ***

Note You need to log in before you can comment on or make changes to this bug.