Bug 457353 - should prefer iso_3166 common_name for territory
should prefer iso_3166 common_name for territory
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-07-30 23:24 EDT by Jens Petersen
Modified: 2015-01-14 18:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 12:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm-lang-common_name.patch (1.71 KB, patch)
2008-07-30 23:27 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Jens Petersen 2008-07-30 23:24:34 EDT
Description of problem:
gdm should follow iso_3166.tab and use the shorter common_name field in
iso_3166.xml when available since it is simpler.

Steps to Reproduce:
1. look at language name for zh_TW in GDM
  
Actual results:
1. "中文 (中華民國)" with tooltip "Chinese (Taiwan, Province of China)"
with contradicting territories.

Expected results:
1. "中文 (台灣)" with tooltip "Chinese (Taiwan)"
with common territory.
Comment 1 Jens Petersen 2008-07-30 23:27:27 EDT
Created attachment 313068 [details]
gdm-lang-common_name.patch

I tested this simple patch and it seems to work ok.
Comment 2 Matthias Clasen 2008-08-01 12:44:26 EDT
Committed upstream, thanks.

Note You need to log in before you can comment on or make changes to this bug.