Bug 457396 - reset full speed USB device using uhci_hcd Canon PowerShot A520 digital camera
reset full speed USB device using uhci_hcd Canon PowerShot A520 digital camera
Status: CLOSED DUPLICATE of bug 387251
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 08:35 EDT by Tony Arie Kolev
Modified: 2008-08-10 06:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-10 06:42:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Arie Kolev 2008-07-31 08:35:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
First of all the problem introduced after upgrading to Fedora Core 9 on same computer and camera hardware that was communicating correctly with Fedora Core 4,5,6.
When connecting the camera error window pops up:
Canon, Inc.Digital IXUS 50 (normal mode)/ IXY Digital 55 (normal mode)/ PowerShot A520 (PTP mode) / PowerShot SD400(normal mode)
Error initializing camera: -114 OS error in camera communication.
When looking in system messages I see device reset/firmware changed:
tail -f /var/log/messages
Jul 31 15:30:56 localhost kernel: hub 1-0:1.0: unable to enumerate USB device on port 1
Jul 31 15:30:56 localhost kernel: usb 2-1: new full speed USB device using uhci_hcd and address 12
Jul 31 15:30:56 localhost kernel: usb 2-1: configuration #1 chosen from 1 choice
Jul 31 15:30:56 localhost kernel: usb 2-1: New USB device found, idVendor=04a9, idProduct=30c1
Jul 31 15:30:56 localhost kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 31 15:30:56 localhost kernel: usb 2-1: Product: Canon Digital Camera
Jul 31 15:30:56 localhost kernel: usb 2-1: Manufacturer: Canon Inc.
Jul 31 15:31:00 localhost kernel: usb 2-1: reset full speed USB device using uhci_hcd and address 12
Jul 31 15:31:00 localhost kernel: usb 2-1: device firmware changed
Jul 31 15:31:00 localhost kernel: usb 2-1: USB disconnect, address 12
Jul 31 15:31:00 localhost kernel: usb 2-1: new full speed USB device using uhci_hcd and address 13
Jul 31 15:31:01 localhost kernel: usb 2-1: configuration #1 chosen from 1 choice
Jul 31 15:31:01 localhost kernel: usb 2-1: New USB device found, idVendor=04a9, idProduct=30c1
Jul 31 15:31:01 localhost kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 31 15:31:01 localhost kernel: usb 2-1: Product: Canon Digital Camera
Jul 31 15:31:01 localhost kernel: usb 2-1: Manufacturer: Canon Inc.
Jul 31 15:31:01 localhost kernel: usb 2-1: reset full speed USB device using uhci_hcd and address 13


Version-Release number of selected component (if applicable):
2.6.25.3-18.fc9.i686

How reproducible:
Always


Steps to Reproduce:
1. Connect digital camera to usb port
2. Power on camera


Actual Results:
When connecting the camera error window pops up

Expected Results:
Import Photos from a Digital Camera window pops up Jul 31 15:30:56 localhost 

Additional info:
Error initializing camera: -114 OS error in camera communication.
Jul 31 15:30:56 localhost kernel: hub 1-0:1.0: unable to enumerate USB device on port 1
Jul 31 15:30:56 localhost kernel: usb 2-1: new full speed USB device using uhci_hcd and address 12
Jul 31 15:30:56 localhost kernel: usb 2-1: configuration #1 chosen from 1 choice
Jul 31 15:30:56 localhost kernel: usb 2-1: New USB device found, idVendor=04a9, idProduct=30c1
Jul 31 15:30:56 localhost kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 31 15:30:56 localhost kernel: usb 2-1: Product: Canon Digital Camera
Jul 31 15:30:56 localhost kernel: usb 2-1: Manufacturer: Canon Inc.
Jul 31 15:31:00 localhost kernel: usb 2-1: reset full speed USB device using uhci_hcd and address 12
Jul 31 15:31:00 localhost kernel: usb 2-1: device firmware changed
Jul 31 15:31:00 localhost kernel: usb 2-1: USB disconnect, address 12
Jul 31 15:31:00 localhost kernel: usb 2-1: new full speed USB device using uhci_hcd and address 13
Jul 31 15:31:01 localhost kernel: usb 2-1: configuration #1 chosen from 1 choice
Jul 31 15:31:01 localhost kernel: usb 2-1: New USB device found, idVendor=04a9, idProduct=30c1
Jul 31 15:31:01 localhost kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 31 15:31:01 localhost kernel: usb 2-1: Product: Canon Digital Camera
Jul 31 15:31:01 localhost kernel: usb 2-1: Manufacturer: Canon Inc.
Jul 31 15:31:01 localhost kernel: usb 2-1: reset full speed USB device using uhci_hcd and address 13
Comment 1 Tony Arie Kolev 2008-08-07 12:01:59 EDT
There is another interesting messages (I have missed in report) when camera connected:

hub 1-0:1.0: unable to enumerate USB device on port 2
usb 2-2: new full speed USB device using uhci_hcd and address 9
usb 2-2: configuration #1 chosen from 1 choice
usb 2-2: New USB device found, idVendor=04a9, idProduct=30c1
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-2: Product: Canon Digital Camera
usb 2-2: Manufacturer: Canon Inc.
usb 2-2: reset full speed USB device using uhci_hcd and address 9
usb 2-2: device firmware changed
usb 2-2: USB disconnect, address 9
usb 2-2: new full speed USB device using uhci_hcd and address 10
gvfsd-gphoto2[14987]: segfault at c ip 004387a0 sp bf81c1cc error 4 in libpthread-2.8.so[431000+15000]
usb 2-2: configuration #1 chosen from 1 choice
usb 2-2: New USB device found, idVendor=04a9, idProduct=30c1
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-2: Product: Canon Digital Camera
usb 2-2: Manufacturer: Canon Inc.
Comment 2 Tony Arie Kolev 2008-08-10 06:42:25 EDT
(In reply to comment #1 @bug 387251)
> Many of Canon related fixes were made in the 2.4.2 gphoto2/libgphoto2 release,
> which is currently in rawhide. I bet it's fixed there :)

Hello, I have a similar problem, described in this bug.

Yes, I tried it, just one thing needed to be explicit mentioned:
Requirements for gphoto2 to be meet, extra 100 packages is needed to
update/install from rawhide. After all communication with Canon camera
surprised me and worked just like it must be. Ok, now nautilus fails to start,
because of library symbol missing:

nautilus

(nautilus:15829): GVFS-RemoteVolumeMonitor-WARNING **: invoking IsSupported()
failed for remote volume monitor with dbus name
org.gtk.Private.HalVolumeMonitor: org.freedesktop.DBus.Error.Spawn.ChildExited:
Launch helper exited with unknown return code 127
Initializing nautilus-image-converter extension
nautilus: symbol lookup error: /usr/lib/gio/modules/libgvfsdbus.so: undefined
symbol: g_set_error_literal

Now I am trying to fix it by applying another 800 packages from rawhide.

Thanks.

*** This bug has been marked as a duplicate of bug 387251 ***

Note You need to log in before you can comment on or make changes to this bug.