Bug 457403 - munin should provide perl-module in a common package
munin should provide perl-module in a common package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: munin (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 10:02 EDT by Roy-Magne Mo
Modified: 2008-10-01 02:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 02:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy-Magne Mo 2008-07-31 10:02:33 EDT
Description of problem:
As of munin 1.2.6, munin-node requires munin package

Version-Release number of selected component (if applicable):
1.2.6-1

How reproducible:
always

Steps to Reproduce:
1. yum install munin-node
2.
3.
  
Actual results:
pulls in munin and all it's dependencies

Expected results:


Additional info:
In 1.2.6 the new Munin perl module is included, or the plugins has been updated
to use this module, not sure about that. But the net effect is that munin-node
can not be installed without munin itself. This perl module should be split into
a munin-common package or a package of it self.
Comment 1 Kevin Fenzi 2008-08-11 23:06:18 EDT
Thanks for spotting this. 

Turns out it's even easier than making a common package. The Munin/Plugin.pm module simply needs to be in the munin-node subpackage. 

I have pushed out a rawhide build with this change. 
Can you confirm that it works now without pulling in munin?
Comment 2 Roy-Magne Mo 2008-08-12 09:25:49 EDT
Works well :) 

[root@osl-lnx45 ~]# rpm -q --provides munin
package munin is not installed
[root@osl-lnx45 ~]# rpm -q --provides munin-node
config(munin-node) = 1.2.6-3
perl(Munin::Plugin)
munin-node = 1.2.6-3

Test was done on Centos 5.2, but should be a valid test.
Comment 3 Fedora Update System 2008-09-08 17:42:24 EDT
munin-1.2.6-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/munin-1.2.6-3.fc9
Comment 4 Fedora Update System 2008-09-08 17:44:14 EDT
munin-1.2.6-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/munin-1.2.6-3.fc8
Comment 5 Fedora Update System 2008-09-11 13:10:06 EDT
munin-1.2.6-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update munin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7930
Comment 6 Fedora Update System 2008-09-11 13:15:44 EDT
munin-1.2.6-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update munin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7971
Comment 7 Fedora Update System 2008-10-01 02:33:06 EDT
munin-1.2.6-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-10-01 02:34:35 EDT
munin-1.2.6-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.