Bug 457469 - Alliance Schematic viewer crashes with _XmRenderTableFinaliseTag() debug info
Alliance Schematic viewer crashes with _XmRenderTableFinaliseTag() debug info
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 368441
  Show dependency treegraph
 
Reported: 2008-07-31 15:28 EDT by Aanjhan Ranganathan
Modified: 2008-09-15 05:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 05:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (330 bytes, patch)
2008-07-31 15:28 EDT, Aanjhan Ranganathan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 439186 None None None Never

  None (edit)
Description Aanjhan Ranganathan 2008-07-31 15:28:41 EDT
Description of problem:
When the help dialog of Alliance
(https://admin.fedoraproject.org/pkgdb/packages/name/alliance) Schematic viewer
or pattern viewer is opened, the application crashes out. Both these
applications depends on lesstif. Upon enabling debuginfo, it was found that the
last crash debug info was with _XmRenderTableFinaliseTag(). Googling landed me
with this Debian bug report
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=439186 which clearly seems to
be a similar crash of another app. As mentioned in that bug report, there seems
to be a missing boundary check in one of the "experimental" code and a simple
patch is also provided. (pasted below too)

Upon investigating further with lesstif source code in Fedora, the patch seems
to have not been applied here and could be the reason for the crash. Request to
patch the file and update as it affects all applications using lesstif2. Thanks
in advance. 

Patch attached.

How reproducible:
Always
Comment 1 Aanjhan Ranganathan 2008-07-31 15:28:41 EDT
Created attachment 313127 [details]
patch
Comment 2 Aanjhan Ranganathan 2008-07-31 15:32:28 EDT
Linked with bug report https://bugzilla.redhat.com/show_bug.cgi?id=368441
Comment 3 Chitlesh GOORAH 2008-07-31 15:43:39 EDT
Please consider that this bug affects some of alliance(from Fedora Electronic
Lab) windows and that we are waiting for an immediate fix. Thank you.
Comment 4 Hans de Goede 2008-08-01 04:06:29 EDT
This has already been fixed (we base our lesstif packages on Debian's and rebase
every so often) in lesstif-0.95.0-26 which is in rawhide.

I'll prepare an lesstrif update to lesstif-0.95.0-26 for F-8 and F-9.
Comment 5 Fedora Update System 2008-08-01 09:47:35 EDT
lesstif-0.95.0-26.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-08-01 09:48:07 EDT
lesstif-0.95.0-26.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-08-07 19:52:29 EDT
lesstif-0.95.0-26.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-08-07 19:53:21 EDT
lesstif-0.95.0-26.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Chitlesh GOORAH 2008-09-15 05:10:57 EDT
Shouldn't this bug be closed now ?
Comment 10 Hans de Goede 2008-09-15 05:52:56 EDT
Yes, bodhi should have done that, closing.

Note You need to log in before you can comment on or make changes to this bug.