Bug 457478 - yum groupinstall doesn't work with clone channels
yum groupinstall doesn't work with clone channels
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.1
All Linux
high Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space02
  Show dependency treegraph
 
Reported: 2008-07-31 16:38 EDT by Jan Pazdziora
Modified: 2009-09-17 02:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 02:59:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-07-31 16:38:07 EDT
Description of problem:

System subscribed to RHEL channel has command yum grouplist and yum groupinstall
working alright. System subscribed to channel cloned from the original one does
not seem to work.

How reproducible:

Deterministic.

Steps to Reproduce:

1. Register system to channel RHEL 5.
2. Run yum grouplist, see that it shows groups.
3. Clone that RHEL 5 channel.
4. Change the base channel of that system.
5. Run yum goruplist again.

Actual results:

No groups shown.

Expected results:

Groups shown as for the original channel.

Additional info:

This bugzilla is an upstream for bug 452046.
Comment 1 Jan Pazdziora 2008-07-31 16:41:43 EDT
There are two problems there:

1) We do not receive the comps information (used bu those yum group* actions)
from hosted in channel synces / channel dumps. We use a hack in
/usr/share/rhn/server/repomd/repository.py, where if the table rhnchannelcomps
is not populated for given channel and the channel label is one of well known,
we return the information we assume hosted would have sent to us.

2) When the channel is cloned, the logic is no longer used for that cloned
channel since the label is different.
Comment 2 Jan Pazdziora 2008-07-31 16:50:47 EDT
Commit 9bb5490a1d4438ea161136101398f9a823e76f3c addresses the point 2. Once we
have the data in the rhnchannelcomps table, cloning the channel will clone the
comps information as well.
Comment 3 Jan Pazdziora 2008-08-01 06:24:25 EDT
Commit 6b8bd42ede5e900a9fc04ba16c1a8a1a0ac5fd13 addresses the point 2 even for
our current situation when the data is not in the database. We now recurse
through the original channels of cloned channels and use the first comps
information we find.
Comment 4 John Matthews 2008-09-11 14:35:31 EDT
Ran on rlx-0-24.rhndev.redhat.com, a Spacewalk 0.2 install with a rhel5 client, looks good.

output below:


Setting up Group Process
clone-rhel-i386 server-5                                                                                                   | 1.4 kB     00:00     
Installed Groups:
   Administration Tools
   Editors
   GNOME Desktop Environment
   Games and Entertainment
   Graphical Internet
   Graphics
   James' X apps.
   James' core apps.
   Legacy Network Server
   Legacy Software Development
   Mail Server
   Network Servers
   Office/Productivity
   Printing Support
   Server Configuration Tools
   Sound and Video
   System Tools
   Text-based Internet
   X Window System
Available Groups:
   Authoring and Publishing
   DNS Name Server
   Development Libraries
   Development Tools
   Engineering and Scientific
   FTP Server
   GNOME Software Development
   Java Development
   KDE (K Desktop Environment)
   KDE Software Development
   MySQL Database
   News Server
   PostgreSQL Database
   Web Server
   Windows File Server
   X Software Development
Done
Comment 5 Miroslav Suchý 2009-09-17 02:59:44 EDT
Spacewalk is released for long time.

Note You need to log in before you can comment on or make changes to this bug.