Bug 457486 - rpmlint should accept "GPLv2 or Artistic" as license
rpmlint should accept "GPLv2 or Artistic" as license
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-07-31 17:49 EDT by Sven Lankes
Modified: 2008-10-23 16:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.84-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-23 16:04:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sven Lankes 2008-07-31 17:49:12 EDT
Description of problem:

rpmlint doesn't accept "GPLv2 or Artistic" as valid license

 W: invalid-license Artistic

Version-Release number of selected component (if applicable):

Comment 1 Sven Lankes 2008-07-31 17:49:41 EDT
snippet from #fedora-devel:

killefiz | spot: is there anything wrong with a package being "GPLv2 or
Artistic" - rpmlint complains but I cannot see why this should be an issue
    spot | killefiz: that should be fine, we just need to fixup rpmlint there
Comment 2 Ville Skyttä 2008-08-01 15:00:06 EDT
rpmlint follows http://fedoraproject.org/wiki/Licensing very closely and "GPLv2
or Artistic" is not listed as a valid short name there... "GPL+ or Artistic" and
"GPLv2+ or Artistic" are, FWIW.  spot?
Comment 3 Tom "spot" Callaway 2008-08-06 12:00:00 EDT
I added it to the list today, in 0.99.

Note You need to log in before you can comment on or make changes to this bug.